OPTEE 3.6.x & AOSP not finishing boot


I downloaded and compiled AOSP & OPTEE 3.6.2
“git clone https://github.com/linaro-swg/optee_android_manifest -b 3.6.2” (first tried 3.6.2, then 3.6.1 - result is the same)

After doing flash-all.sh I can see over HiKey960 UART that it boots and then gets stuck. Just every second prints out this:

[ 23.687303] ServiceManagement: Waited one second for android.hardware.keymaster@3.0::IKeymasterDevice/default. Waiting another…

No UI over HDMI. No USB device for ADB. No console over UART (by pressing enter I should see command prompt).

Is this some known issue, or am I doing something wrong? I have tried this on two different HiKey960 boards (Lemaker & HiHope). Couldn’t find anybody having same issue.

@chain I’ll need some time to test this and get back to you.

@chain I can reproduce. Currently trying to fix but no eta yet. In the meantime, if possible, please use v3.4.2 release.

1 Like

@chain Sorry for the delay. Please see AOSP+OP-TEE build and sync issue in Hikey960 - #34 by vchong if this still applies.