No image when building Android from source for Hikey960


#1

Hi all,

I’m not getting an image on my monitor when building from source… :frowning:

If I install the latest pre-built factory image (i.e hikey960-linaro-2018.02.08-factory-633bc08c) by using flash-all.sh, my hikey960 boots up nicely, and my Dell u2415b HDMI monitor has a beautiful image.

On the other hand, if I build from source by following: https://www.youtube.com/watch?v=e3jYbVo1Dfc “How To Install Android O on 96Boards LeMaker HiKey960”, my hikey960 boots up, but no image or even a flick appears on my monitor. I also tested with a different DELL monitor and the result was the same.

Looking at other threads in the forum I changed the file: “device/linaro/hikey/hikey960/BoardConfig.mk” by adding the following line:

BOARD_KERNEL_CMDLINE += video=HDMI-A-1:1920x1080@60

Then I re-ran “make bootimage -j4” and flashed boot, dts, system, cache and userdata. I tried all different resolutions listed below, but I didn’t get any image at all.

1280x720@58
1280x720@60
1920x1080@58
1920x1080@60
800x480@64

If I look into dmesg for HDMI, this is what I get:


hikey960:/ # dmesg | grep -i hdmi
[ 0.000000] Kernel command line: androidboot.hardware=hikey960 console=ttyFIQ0 androidboot.console=ttyFIQ0 firmware_class.path=/system/etc/firmware loglevel=15 video=HDMI-A-1:1920x1080@60 buildvariant=userdebug androidboot.swtype=normal fastboot_version=DailyBuild_201706021648_FASTBOOT setup_logctl=1 fastbootdmd=0 enter_recovery=0 androidboot.mode=normal low_volt_flag=1 boardid=0x000014b5 normal_reset_type=coldboot ddr_die=3072M@0M efuse_status=2 androidboot.serialno=0123456789ABCDEF himntn=111111111111111010111111101001100010001 boot_slice=0x0002e237 reboot_reason=AP_S_COLDBOOT recovery_update=0 userlock=locked bootlock=unlocked hw_bfm_enable=0 ddr_density=3 swiotlb=2 mdmreglogbase=0x00000000 mdmreglogsize=0x00000000 modem_socp_enable=0 androidboot.hardware=HiKey960 androidboot.veritymode=enforcing androidboot.verifiedbootstate=ORANGE ufs_product_name=THGBF7G8K4LBATRC format_data=1 cpu_buck_reg=0x;; androidboot.ddrsize=3 kce_status=1 console=ttyAMA6,115200
[ 2.896542] [drm] wait for external HDMI bridge driver.
[ 8.974871] [drm] client change to HDMI
[ 10.340585] asoc-simple-card soc:sound: hdmi-hifi.0 <-> e804f800.hisi_i2s mapping ok
[ 10.433539] #0: hikey-hdmi


Does anybody know what am I missing or doing wrong?

Thanks


#2

Did you correctly follow the building steps (https://source.android.com/setup/devices), including:

2. Download and extract binaries into the Android source tree:

wget https://dl.google.com/dl/android/aosp/arm-hikey960-OPR-cf4e0c80.tgz
tar xzf arm-hikey960-OPR-cf4e0c80.tgz
./extract-arm-hikey960.sh

#3

Hi @Loic,

I repeated all the steps from scratch making sure I included the binaries and now it works. I had to setup my environment a couple of times, thus I guess I skipped that step in the few last attempts,

It is working now, thanks for your help!


#4

Please tell the latest version of HDMI binary file “arm-hikey960-XXX-*”


#5

These files are no longer needed. Everything you need gets pulled down when you run repo sync.