No HDMI on Android Marshmallow (solved)


#1

I followed the Qualcomm guide to build Android 6 Marshmallow from source using the guide at https://developer.qualcomm.com/download/db410c/linux-android-software-build-and-installation-guide.pdf and flashed the images. But now I don’t have any HDMI output any longer. It used to work using latest Debian and the Android 5 images provided as downloads. I can adb shell into the board. What can I do to make it work?

Thanks.


#2

solved. bricked the board, reflashed with release 99 build, reflashed with android marshmallow, had more patience and then suddenly the display came up. now I have no mouse and tons of errors in logcat, but thatś not an issue at this point.


#3

Hi @Genoil

Yes Android takes a really long time to come up, particularly the first time after flashing.

Your mouse and keyboard will not work if you have anything plugged into the micro-USB port. This is expected behavior.

Full disclosure: I am an employee of Qualcomm Canada, any opinions I have expressed in this or any other post may not reflect the opinions of my employer.


#4

Thanks! I’m back to no HDMI now but this time it is on purpose. Trying to bring up a DSI panel, but no luck yet. The porting guide is quite cryptic I have to say. Do you know any good resources for step by step debugging this?