No connection after reloading module wcn36xx on db410c linaro


#1

I want to reload the wcn36xx module with the debug_mask parameter set.
I run:

root@linaro-developer:~# modprobe wcn36xx -r

in order to unload it.
then when running:

root@linaro-developer:~# modprobe wcn36xx debug_mask=0xffffffff

at first time I get:

[ 2522.065080] qcom_wcnss_ctrl pronto.wcnss: channel WLAN_CTRL is busy [ 2522.065131] wcn36xx: ERROR failed to open WLAN_CTRL channel [ 2522.070448] wcn36xx: probe of smd:pronto:wcnss:wifi failed with error -16

then running again:

root@linaro-developer:~# modprobe wcn36xx debug_mask=0xffffffff

there are no error messages but running “ifconfig” shows only loopback, and running:

root@linaro-developer:~# nmcli dev wifi connect mywifi Error: No Wi-Fi device found.

upon booting, the the wifi is automatically connected. Only trying to unload and load it doesn’t connect.

I run on dragonboard410c with:

root@linaro-developer:~# uname -a
Linux linaro-developer 4.4.23-linaro-lt-qcom #3 SMP PREEMPT Tue Feb 7 08:46:18 IST 2017 aarch64 GNU/Linux


#2

This is a bug in the wcn36xx driver, when cleaning up during removal I don’t close the control channel and hence when we try to probe again upon insmod the channel is found to still be “open”.

I created https://bugs.96boards.org/show_bug.cgi?id=490 to track this.

Thanks for reporting this!

Regards,
Bjorn