My Dragonboard won't boot. Brand new board, need help... :(


#1

I purchased a DragonBoard last month and just powered it up for the first time today, using the given instructions here ‘Starting the board for the first time’ with a 7" HDMI display and a 9V PSU. I first tried the stock image, Android and it didn’t put out any HDMI. As such I then reached out to try Debian Linux too. It did not display HDMI either to my display.

I validated the cable, input port and display using a different HDMI device. With that cable & port driving the display, worked just fine so the display and connection is ok. How to debug further? Thoughts?

sooooooo strange. And a huge bummer! :frowning:


#2

Hi @justinm,

The 96Boards is difficult to understand what is happening when the HDMI display does not show anything.
I also suffered the HDMI displays and end-up buying three.
The HDMI which supports 60Hz seem to have a good luck.

Also, have you tried UART serial console screen in the past?
The serial console will allow you to see the boot messages and able to login even the HDMI display is not showing the screen.
http://www.96boards.org/forums/topic/short-into-to-start-your-dragonboard-410c-with-serial-console/


#3

Debian (and the debian SD card installer) is configured to flash an LED when the kernel is booted. This helps us see whether or not the board is working.

Did you observe any lights when you tried to boot debian (and which install method did you use)?


#4

I used the SD Card method for installation -

<br>

After completion, removal of the PSU, removal of the SD and then I reapply the PSU, User LED 4 performs the following behavior

  • - Apply PSU
  • - 8 seconds later, User LED 4 turns on
  • - ~24 seconds later User LED 4 turns off & remains off

<br>

this is the correct method? thoughts??


#5

And thank you Akira, this is perfect as a next step! I purchased one of the Seeed UART Adapter Boards today, I’ll be in touch once I get to try it out! :slight_smile:

Thank you guys!!


#6

I had same issue and turned out to be the microUSB cable. Make sure you are using a data + power cable and not just a power one. Used a cable from my old Nokia Windows Phone to get it working. Try an Android phone cable if you have one.


#7

you should use the correct cable
not the HDMI converter

try to use the “REAL” HDMI cable
not the HDMI converter


#8

Hi,
My Dragonboard 410c won’t boot up. I was able to boot up the android environment when I first got it, but after trying to install linux onto it with the SD card method, my board won’t start up. With the HDMI plugged in, nothing shows up on my screen(it used to though). When I reset all the S6 pins to off, the board should load the existing android environment right? When I plug in the power, the BT led flashes(blue). Nothing else happens after. Does this imply that the board is stuck in the installation of linux?


#9

Hello

Do you have access to any 1.8 volt UART interface (e.g. 96boards-uart,
TTL-232RG-VREG1V8-WE or a sneaky hack such as this
one
.

UART can be very helpful for diagnosing problems like this.

Daniel.


#10

Hi,
No I don’t have access to these.


#11

Hi, i have the same problem, my dragonBoard was workind with debian, but when i opened broswer internet, my dragon turn off, and now days the led 1 is flashing, but the display is but the screen is black, help me!!!


#12

Not every computer handles displays the same way. You can come up with situations where a perfectly good monitor just doesn’t like to work with a perfectly good computer. Try the monitor on a different computer and it works, try a different monitor on the same computer and it works.

My suggestion is to first try a different monitor (and I mean actually different, like instead of that original 7" display this thread started with, maybe a 50 inch television) on the dragonboard. If it still doesn’t work, then it becomes time to jump into more serious debugging.

Similar problem can be observed when you are messing around with the OS / kernel / etc. For instance, the “factory” Android builds use the binary qualcomm display drivers, whereas the debian builds use freedreno. Even between debian builds and more recent AOSP Master builds (where both use freedreno), there are enough things different in the display stack that strange variations can happen.


#13

To be clear this is not the same problem as was previously reported in this thread (OP reported the BT LED jammed on).

Have you attempted SD card recovery? https://www.96boards.org/documentation/consumer/dragonboard/dragonboard410c/installation/board-recovery.md.html