L-loader recovery failed


#1

Dear All,

Recently I’ve received this board, compiled OP-TEE stuff from scratch and flashed … bricking successful!
Three days of googling and investigation gave no results.

Board recovery process described on github finished with pretty standard “failed” message that repeated infinitely. When powering on the board with closed links 1-2 and 3-4 some debug message (NULL packet) is appears on serial console but then recovery process is stuck on hisi-idt.py script.

What was tried and checked:

  1. Different Ubuntu machines, checked all USB ports (2.0, 3.0);
  2. Different micro-USB cables;
  3. All other USB cables are disconnected from board, SD card is ejected;
  4. Python version is 2.7;
  5. modemmanager program is not installed on the system;
  6. Tried to use C version hisi-idt got from parallel thread;
  7. Different baud rates.

After adding debug messages to hisi-idt.py script, found that ACK (0x55) byte didn’t received on sendheadframe command. You can see additional log here.

Will be grateful for any ideas.

P.S. Is it normal message for flash procedure?
seclock: hisi_secboot_get_lockstate: nve_direct_access read error


#2

There might be some confusion here between the hikey and hikey960 board. Your post seems to be about hikey, but your log seems to be from the hikey960. They’re different boards and use different images. If you used the images for a different board, I guess chances are high to brick the board.

What and how did you compile from scratch? How did you flash? Please provide details.


#3

Well, sudo ./recovery-flash.sh /dev/ttyUSBx command from https://github.com/96boards-hikey/tools-images-hikey960 guide did the trick!


#4

Dear vchong,

I’ve used this guide https://github.com/OP-TEE/build/blob/master/docs/hikey.md (Debian based build) in order to build firmware for HiKey 960. Build process is pretty automated by OP-TEE developers, so I simply run “make” and “make flash”. In any case, l-loader problem is resolved and I can proceed to investigate other issues that is out of scope of this thread.

Thanks for your support.


#5

@Kiirkh So you have a hikey960, which means you CANNOT use https://github.com/OP-TEE/build/blob/master/docs/hikey.md else you might stand to brick your board again. This site currently provides support for hikey ONLY. Hikey960 is currently being worked on and not complete yet. No ETA yet but hopefully soon. Will try to keep you posted.


#6

@vchong Sorry to hear that. I surely hope working version for Hikey 960 will be available in foreseeable future. And yes, you’re right, my board was bricked again when I’ve tried to flash it with OP-TEE.


#7

@Kiirkh OP-TEE is now supported on hikey960.