KDE System Settings items are hanging


#1

I have the latest linaro Buster build #173 installed with the fastboot method on DB820c.
OS is updated, upgraded.
Logged in as linaro/linaro

On the KDE ALIP UI I do

  1. Click Start (lower left icon)
  2. Preferences
  3. KDE System Settings

I get to the KDE System Settings dialog box (see below).
None of the functionality, list item or menu item like “Application Style”, “Startup and Shutdown”, etc. is working, functional or operational.

Expected behavior: Working
Actual Behaviour: Hanging with a spinning mouse cursor.

I have to restart the GUI with sudo systemctl restart sddm from the SSH console.


#2

I didn’t think we shipped a KDE ALIP image. Did you install KDE yourself?


#3

I have the latest linaro Buster build #173 installed with the fastboot method on DB820c.
OS is updated, upgraded.


#4

@danielt, we ship with LxQt desktop… which brings in some KDE dependencies… (sadly I would say, but this is very subjective, and only my opinion :wink:


#5

I am OK to change to any GUI that works.
What are the steps, please?


#6

any standard desktop (xfce, lxde, gnome-shell… ) should work well, especially on 820c (gnome-shell is known to be slow on 410c, mostly because of RAM limitation). you are running an almost unmodified Debian, so you can apt-get any other desktop env.

we picked LxQt for various reasons as the ‘default’ for our images, and we are not planning to change it soon.


#7

That’s great. I’d pick something that works.
This does not!

  • No settings!
  • No file manager!
  • No great experience!

#8

ok, it shouldn’t be as bad as that… i will have to check on my side actually…


#9

Correct. It shouldn’t.
I would not post if there is no reason. Thx.


#10

Just tried installing the latest image (still #173) and I am able to use the KDE System Settings immediately after install. I tried Start -> Preferences -> KDE System Settings and then Application Style -> Border size: Huge -> Apply and observed the window borders growing.

I’ve just done an apt upgrade but I’m typing this on DB820C itself… so I’ll be back in a moment after I’ve rebooted.


#11

After the reboot the preference are still working for me… and there is a file manager under Start -> Accessories:slight_smile:


#12

Here are the commands I did:

sudo apt update && \
 sudo apt upgrade -y && \
 sudo apt dist-upgrade -u -y && \
 sudo apt-get clean && \
 sudo apt autoremove -y && \
 sudo apt-get install -y \
  apt-utils \
  ca-certificates \
  lsb-release \
  locales \
  curl \
  wget \
  unzip \
  procps \
  tar \
  openssh-server \
  htop \
  dos2unix \
  nano \
  mc \
  tmux \
# .NET Core 2.1
 libunwind8 gettext apt-transport-https \
# Docker
 gnupg2 software-properties-common \
# Sensor Board
 arduino-mk arduino git build-essential cmake bison doxygen graphviz python-sphinx python3-sphinx libudev-dev libgtest-dev libjson-c-dev autoconf libtool python-dev python-pip python3-pip pkg-config libpcre3-dev libjpeg-dev clang-6.0 libclang-6.0-dev python-clang-6.0 \
 # && rm -rf /var/lib/apt/lists/* \
 && curl -sSL https://aka.ms/getvsdbgshbeta | bash /dev/stdin -v latest -r linux-arm -l /vsdbg

#13

What would be an alternative GUI?


#14

What would be an alternative GUI?

Depends on your taste [earlier comments make it sound like you like
your file manager to draw icons on your desktop which means your
taste won’t match mine :wink: ].

Either way if you sudo apt install tasksel and then sudo tasksel you
should get a wide choice.

Please try this before you customize your system much though! If it
breaks you don’t have to keep both halves, but you probably will have
to reinstall from scratch.


#15

Actually, come to think of it, if you are going to use tasksel to
install a desktop of your choice you might prefer to start from
the developer (no GUI) image…


#16

That’s a great idea, Daniel. I’ll try it at some point.
I’ll try to fix LxQt first to help fellow pioneers.
I thought I have KDE from the labels, but I understand now thats’ LxQt.


#17

GUI that people like:

Best Debian GUI