Issues whit buildung android


#1

Hi!

I’ve downloaded the linux_android_board_support_package_vla.br_.1.2.4-01810-8x16.0-3.zip form Qualcomm’s website and i have some issues while building.
I get wierd errors like this:

host SharedLib: libcompiler_rt_32 (out/host/linux-x86/obj32/lib/libcompiler_rt.so)
/home/balika011/Mobiles/DragonBoard410c/linux_android_board_support_package_vla.br_.1.2.4-01810-8x16.0-3/APQ8016_410C_LA.BR.1.2.4-01810-8x16.0_5.1.1_Lollipop_P2/prebuilts/gcc/linux-x86/host/x86_64-linux-glibc2.11-4.6/bin/…/lib/gcc/x86_64-linux/4.6/…/…/…/…/x86_64-linux/bin/ld: error: out/host/linux-x86/obj32/STATIC_LIBRARIES/libcompiler_rt_intermediates/libcompiler_rt.a(eprintf.o): unsupported reloc 43 against global symbol stderr
external/compiler-rt/lib/builtins/eprintf.c:32: error: unsupported reloc 43
collect2: ld returned 1 exit status
build/core/host_shared_library_internal

Does anyone knows how to fix this?


#2

Hi @balika011,

Do you mind teaching us where do you download the file?
linux_android_board_support_package_vla.br_.1.2.4-01810-8×16.0-3.zip

I searched around but just could not find it.


#3

Akira,

from here: https://developer.qualcomm.com/hardware/dragonboard-410c/tools

nico


#4

I’m running Ubuntu 16.04 with Gnome 3 if it helps.
Linux balika011-HP-ENVY-17-Notebook-PC 4.4.0-14-generic #30-Ubuntu SMP Tue Mar 15 13:04:17 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux


#5

Hi,
As yet I cannot answer your question because I face an earlier problem in running the DB410c_build.sh script supplied as part of the zip file.
Maybe you are someone else can help…?
My problem is that after 6 hours of downloading, the scripts attempts to apply patches… but in my case the first patch fails:-
Applying patches …
applying patches on ./bootable/bootloader/lk …
./DB410c_build.sh: line 44: cd: /home/john/AndroidDragon/linux_android_board_support_package_vla.br_.1.2.4-01810-8x16.0-3/APQ8016_410C_LA.BR.1.2.4-01810-8x16.0_5.1.1_Lollipop_P2/./bootable/bootloader/lk: No such file or directory
./bootable/bootloader/lk does not exist in BUILDROOT:/home/john/AndroidDragon/linux_android_board_support_package_vla.br_.1.2.4-01810-8x16.0-3/APQ8016_410C_LA.BR.1.2.4-01810-8x16.0_5.1.1_Lollipop_P2

The directory doesn’t exist and the file that the ‘./PATCH_8x16_129905_410c_LA.BR.1.2.4-01810-8x16.0/bootable/bootloader/lk/0001-lk-aboot-device-unlocked-patch-for-fastboot-flashing.patch’ is trying to patch ‘app/aboot/aboot.c’ doesn’t exist anywhere in the downloaded sources.

I presume some part of the download has failed - but there were no ‘error breaks’ during the download so I’m confused…
I’m running the script in a bash shell with root privileges (sudo su) - maybe this is a problem?
I’ve tried running on two different Virtual Machines - one a Ubuntu 14.04LTS, the other Ubuntu 12.04LTS - both give the same problem.

If I can get past this stage, I may be able to help with your problem Balika011


#6

Run these:
cd APQ8016_410C_LA.BR.1.2.4-01810-8x16.0_5.1.1_Lollipop_P2
repo sync


#7

Hello, I met the same problem than Balika …

During last 2 days, I tried to retrieve Android source code with script DB410c_build.sh. But it fails with patch on bootloader/lk. It’s normal because the repo init failed to reach end of the manifest file (I compared .repo/projects to my manifest.xml). I try to fetch manually missing projects, several projects fail with “remote HEAD with unreferenced HEAD” …

How can I have something that works ?

Thanks in advance

Regards,

Mickael


#8

Hello Guys,
Were any of you able to fix this issue I am facing with the same error…


#9

What happens if you just retry a few times (dosn’t the repo sync resume where it left off?).


#10

I tried couple of times, it seems like the repo finishes without error but the folder where the script trying to apply the patches is empty. Even my friend tried it on his machine with the same error… maybe something wrong with the repo… I will do some more investigation.


#11

from the script file , patches are applying from here, and i see patches are available. https://www.codeaurora.org/patches/quic/la/PATCH_8x16_129905_410c_LA.BR.1.2.4-01810-8x16.0.tar.gz

are you facing any conflicts while applying the patches ?
can you please let me know exact issue you facing.

please make sure the Linux Android build set up pre-requests from here https://developer.qualcomm.com/download/db410c/linux-android-software-build-and-installation-guide.pdf

Thanks
Ramesh


#12

Hello guys,

It failed at the applying patches because there was no folder structure created to be patched. The script was going on even when the syncing process fails. I tried to build with host system Ubuntu 16.04. when I finally changed my virtual machine to the one that in the guide 12.xx it was successfully build…

Probably something was wrong with the preinstalled libraries at the newer version.

Thank You guys anyway for the tips and tricks!
Attila