Installing libluajit-5.1-dev on DragonBoard 410c


#1

Hi All

I am trying to install a certain package (“EFL”) on my DragonBoard. During ./configure I am getting the following error:

configure: error: pkg-config missing luajit >=2.0.0

I cannot seem to find the right package to install. I believe, I would need to do this:

sudo apt-get install libluajit-5.1-dev

But that results in:

E: Unable to locate package libluajit-5.1-dev
E: Couldn’t find any package by reges ‘libluajit-5.1-dev’

I can “see” the package at https://packages.debian.org/sid/libluajit-5.1-dev, but I don’t know how to tell my DragonBoard to install it. I have tried all sorts of things, including wildcards (like “libluajit*”), but I am having little success. What I do have installed by now is this:

linaro@linaro-alip:~$ dpkg --get-selections | grep lua
liblua5.1-0:arm64 install
liblua5.1-0-dev:arm64 install
liblua5.2-0:arm64 install
liblua5.2-0-dev:arm64 install
liblua50 install
liblua50-dev install
libluabind-dbg install
libluabind-dev install
libluabind-doc install
libluabind-examples install
libluabind0.9.1 install
libluajit-5.1-common install
liblualib50 install
liblualib50-dev install
lua5.2 install
lua50 install

I have basically installed everything, that would even remotely have to do with lua, but I would think that I am still missing the above libluajit-5.1-dev package.

Any ideas anyone?

Thanks
Thomas


#2

on the package page you are looking, you can see that the packages are not built for arm64. upstream might not work (yet) on arm64, i am not sure. I think arm64 support was added in 2.1 upstream. can you investigate that?

also, you are pointing to ‘sid’ branch of Debian, the current images are still based on ‘jessie’ (and the next release will be on testing/stretch).