Install Google Playstore on Android

I’m trying to install Google play store on DragonBoard 410c Android os. I installed Google Play service.apk, GoogleLoginServices.apk, GoogleServiceFramework.apk and Google play store.apk. Now the play store is opening but its showing “server Error”. Anyone worked on this, please give suggestion to resolve the issue.

Best Regards

I was about to try this by installing the Google App Package “GApps” rather installing all these apps.
That is the way we install Google play (and else) onto the phones.
I crashed trying it… and now working on using the mezzanine :-D, so will try another time.
Did you try to install GApps?

hi marc
I try to install Gapps but it’s failed.then I try to install each main apk files in Gapps package manually, some application is showing NO_CIRTIFICATES. That also didn’t work.
Did u try anything else ?

OH! Great so you tried too :smiley:
GApps is probably the wrong way.
No I did not try anything else.
Actually working on an app to handle the GPIOs on the mezzanine.

Regarding Google Play: I use ApkPure instead where I found all what I needed so far :slight_smile:

We will see if someone else can help or if you find yourself a better way.

Have a nice day.

ok… let’s see , is any others did this or not

Play store and all google apps are working now,

copy Google Play service.apk,GoogleServiceFramework.apk and Google play store.apk into the DragonBoard “/system/priv-app/” directory and restart the system . it will work … enjoy :slight_smile:

Great, but I am not an expert as you are and need some of your help.
I downloaded the 3 files and obviously they do not named as you wrote, this depending of the version.
So first question: Did you renamed the files? If so, what name?

The system/priv-app is a readable directory. I cannot change the mode. If I do a remount of the system directory I get other “Failed to push selection: Operation not permitted”, etc, etc,.
Second question how did you copy these files?

Thank you to give me more indication on how to proceed.

you need to mount the system directory as read-write
To mount use the commands . get root access. go to adb shell
#mount -o remount,rw /system

to copy use : #adb push file.apk /system/priv-app/

Have a nice day

hi marc
No need of changing the file name , you can copy as it is.

Great! Terzon your are the best :smiley:
I succeeded for the installation but now cannot register.
In either way, using known account or creating new account get the message at the end "There was a problem communicating with with Google servers"
Probably uploaded the wrong versions.
I am running Google Play Services 9.6.83
Google Play Store 7.0.16.H-all
Google Service Framework 5.1-1743759

If you have more info for me I would appreciate.
Thanks for helping

More info my Google Play Services code is 9.6.83(240-133…)

Hi marc

just check is date and time are correct on the android

Thank you Terzon,
I already checked this, but made a double check just to be sure. The date/time is OK.

I reinstall all, no difference.

Strange, Google services works! once it asked me for the location after a reboot, so it is active.
Also I can see the 3 apps running.

My account is OK, I created it from the Dragonboard itself and check it from my PC.

Could it be that I used the same phone number as my mobile phone account to receive the G-code when registering?
I think Google let up to 5 accounts on the same phone but this is not the same phone…
I mean I have now 2 accounts on the same phone number. But 2 different device ID. I do not know if Google care about this.

Another question, did you root the Dragonboard by any way?

Thanks a lot for your support.

hi marc
do one thing, download google service framework older version and just try it.
for me also it showed first then I installed framework 4.04 it worked .

Yeeeh Terzon!!! It was not the solution but fooling around installing uninstalling made it.

For me it did not run with the 4.04 version it just crashed.
Did data clear and sits there at "checking info"
Tried again to reinstall the version 5.1 and… “checking info” for ever.

Reinstall the full sets with the 4.04 and crashed, reinstall version 5.1 and runs…
What a jungle route :smiley:

Anyway thank you so much for your help and experience.

Hi Terzon,
I am working on andriod 5.1.1.And I want to install Google Play services on DB410c.
Can you give information about link google Play service.apk,GoogleServiceFramework.apk and Google play store.apk,these Apks.
And where from they get download?

Thank for Advance,

Hello Terzon,

I installed Google play store version - 8.8.12, play services -11.9.75, services framework - 6.0.1, and login service in android 6.0.1, but couldn’t register in the google account because of error in cannot connect to the google server at the moment.

Can anyone please help me on this?


Hi jmjobin,

Can you please tell us exact android version apk names to install Google play on Dragonboard 410c.

I need to work with GCM(cloud messaging) where google play services are mandatory.

Please help me also where to download this APK.

Dragonboard 410c current android version 5.1.1.

Appreciate your help.