I2cdetect returns Error on I2cBus 3


#1

Hi. There are 5 i2c busses on the dragonboard 820c, atleast that is what I see when I run “ls /dev/i2c*”.
When I try to detect on bus 3 I get an error. I run “sudo i2cdetect -r 3” and get “Error: Bus doesn’t support detection commands”. Does anyone know why and what this error means?

Thanks,
kimbo


#2

I suspect that your i2c-3 is the I2C/CCI camera adapter, and this one does not support SMBUS (used by i2cdetect). You can have a list of adapter functionalities with i2cdetect -F and adapter name is specified in /sys/class/i2c-dev/i2c-3/name.


#3

Hi Loic,
I can see that i2c-3 does not support smbus:

root@linaro-alip:/home/linaro/sl/scripts# i2cdetect -F 3
Functionalities implemented by /dev/i2c-3:
I2C yes
SMBus Quick Command no
SMBus Send Byte no
SMBus Receive Byte no
SMBus Write Byte no
SMBus Read Byte no
SMBus Write Word no
SMBus Read Word no
SMBus Process Call no
SMBus Block Write no
SMBus Block Read no
SMBus Block Process Call no
SMBus PEC no
I2C Block Write no
I2C Block Read no
root@linaro-alip:/home/linaro/sl/scripts#

Thanks,
Kim