i2c-EEPROM Access on DragonBoard410c

96boards

#21

I was taking about board from different vendor.


#22

Judging from your kernel version number you are running a very old relase. Do you see the same behaviour on recent releases?


#23

Your eeprom is compatible with 100 kHz.

I can almost guarantee that the problem is in how you are wiring it. Share your schematics so that we can help you figure out what is going wrong.


#24

I have figured it out why EEPROM was not getting detected. It was because of QCOM_CCI driver in my version of kernel doesn’t support standard I2C interfaces. When I disabled “qcom,cci” flag from device tree and used the platform I2C driver, It started working.

Thanks all for your help .