I can't see my db410c using ./adb devices


#1

I can not see my devices after using ./adb devices

I tried to use adb kill-server then adb start-server again ,but nothing works it still not recognized my devices and there is not devices after ./adb devices !
what should i do ?


#2

Hi @hathout,

Yes, that happens.
I think you are trying to connect to Android on your dragonboard 410c using ADB from your laptop with microUSB cable.
Unfortunately, the current 96Boards can not use the USB connector with your USB mouse and microUSB connector at the same time.

Would you mind trying without connecting anything on the two USB ports on DragonBoard 410C and only using microUSB connector on the DragonBoard?

Or would you mind trying to connect to ABD over TCP like written bellow?


#3

It’s not working even without the mouse USB.


#4

Hi @hathout,

I am not sure too,

I download the SD card image from here and installed to my DragonBoard.
https://github.com/96boards/documentation/wiki/Dragonboard%E2%84%A2-410c-QC-Android-Download#your-build-choice

I used the USB mouse and keyboard during the installation.
And I removed the USB mouse and keyboard.
I booted with noting connected on the USB port but only connecting microUSB cable with the host PC.

This is the messages it showed on my Ubuntu PC connected to the DragonBoard 410c.


$ sudo adb devices
List of devices attached 
31c82310	device


#5

I do all these things.

sudo adb devices
List of devices attached

and nothing behind just waiting for a new command !!!


#6

Have you tried following the instructions in section three of this guide?: https://developer.qualcomm.com/download/db410c/linux-android-software-build-and-installation-guide.pdf