How to install OS

Hi,

There is a link from “Linaro supported operating systems based on Debian” but it does not go anywhere.

How do I install the OS?

Regards,
SImon

The Developerbox was all about providing firmware that makes it easy to install third-party operating systems (and it predates SystemReady which is trying to make that the normal case).

Once the upstream distros were all booting nicely then I believe the Linaro images were discontinued.

PS enterprise: developerbox: Remove references to Linaro support OS by daniel-thompson · Pull Request #942 · 96boards/documentation · GitHub :wink:

Hi Daniel,

Thanks for the info.

‘Booting nicely’ might need a definition :slight_smile:

I am not sure how to make Debian boot. It just hangs and I am not sure how to get any sort of grub prompt as it seemed to die before grub. I saw nothing on the screen.

I was able to install Ubuntu but only found the server version so I’m not sure how to get a GUI.

I’d like to use either Debian or Ubuntu if possible but I do need a GUI.

Regards,
Simon

Hi again,

Actually, even with Ubuntu server it has taken over an hour to install grub so far. I’ll leave it overnight and see what happens.

Regards,
Simon

Are you using a GT-710 card?

Hi Daniel,

Yes, the one it came with. It stuck on installing grub and seems to have hung now.

Regards,
Simon

The stuck in install grub case is an annoying problem (that was never tracked down) related to the jumper switch to work around the PCIe silicon bugs. The main reason it wasn’t tracked down is that it is an intermittent problem that didn’t bite me when I was putting the docs together.

It can be avoided but it isn’t really very nice. Basically switch the jumper off (so the workaround does not deploy) and boot with modprobe.blacklist=nouveau on the kernel command line (e.g. use just the efi framebuffer for the installer UI). When the installer suggests you should reboot the machine then flicker the jumper back before rebooting.

I’m afraid I don’t know what has happened to the Debian installer. I haven’t tested anything on Developerbox (or provided it with surplus electrons) for a year or two now.

Hi Daniel,

OK thank you. I tried again with what I thought was the jumper the other way. It worked! Except then I found I hadn’t changed the jumper. So I’m not sure but in any case I have Ubuntu on it now!

I am surprised at how slow it is. But it is cool to have a real hard drive in a computer again!

Thank you for helping.

  • Simon

Just wanted to add I am seeing this issue too -

I am trying to install Debian iso (debian-testing-arm64-DVD-1.iso) and it hangs at “Choose the language” screen.

My jumper (DSW3) was all set default (OFF) - I tried moving them all to ON, no change.

I’ve also tried the modprobe.blacklist=nouveau edit in grub kernel options.

Going to try Ubuntu now since that looked like a win for sglass68.

Best,
Evan

Ubuntu installed for me.

I added modprobe.blacklist=nouveau and removed “quiet splash —” in the Grub kernel options.
I also removed the line for “gfxmode” (this may not have been necessary)