How to install GUI based debian


#1

HI, I recently purchased DragonBoard410c. It came with Android preloaded, Android is booting fine.
I want to install debian with GUI support. I tried to follow instructions of “SD Card Method - Install and boot from eMMC”. But as shown in the installation page, I am not getting GUI screen which is required to install image from SD card to eMMC.
My board is directly showing me tty1 command prompt terminal of linaro.
Can anyone guide me to choose correct image. As I want finally want GUI based desktop for my development.
Thank You.


#2

Could you please attach dmesg log ?
What image/release did you download ?


#3


From the above link, I downloaded (Option 1) SD Card Image - Install and boot from eMMC. And followed the installation instruction.


#4

For testing purpose could you try the option 2 (boot from sdcard) and le me know if you meet the same issue.


#5

I think we’ve seen this problem before. It occurs when the SD controller reports an error… the kernel reacts to the error by remounting the SD card read-only. This prevents the GUI installer from starting up, hence @atulchavan sees a text login prompt instead.

@atulchavan: Have you got a different SD card you can try? Sometimes using an older (or newer) card makes this problem go away.


#6

Correct, btw @atulchavan, Is your card a Sandisk SDHC/UHS?


#7

Yes I am using SanDisk Ultra 16 GB micro SDHC.
I will try with some other SD card as per your suggestion. Thank You.


#8

Ok, It would be interesting if you could give me the dmesg output of the boot with Sandisk (for debugging purpose on our side). We currently trying to fix a sporadic issue with some SDHC SDCARDs.


#9

Hi Danielt and Loic, your point is correct.
I tried same thing with “SanDisk 8GB MicroSDHC class 4” and it worked fine. But when I am doing with “SanDisk Ultra A1 16GB Class 10 Ultra microSD UHS-I” it wont display GUI required for installation process.
I would like to provide you debug messages when we are using SanDisk 16 GB card. How to capture debug message at the boot time. Is it I have to use UART (J8) for debugging? Sorry I have recently started exploring DragonBoard 410c, so please guide me. Thank You.


#10

No prob, a UART/Serial connection is always useful but I understand that you don’t have adapter. Nevermind, when you boot on the Clas10 card you said a terminal appears instead of the standard installation UI. You should then be able to logging as linaro or root user and enter dmesg command. You can even redirect dmesg output to a file (e.g. dmesg > /dmesg.txt) so that you will be able to retrieve it on your host computer when inserting the card.


#11

Er… the filesystem is read-only which will make it hard to store the dmesg output in /. Copying to a USB stick might be more robust!

@atulchavan: If you don’t use the command line much it would be something like below (which is a best guess from my head so instructions may not be perfect… and it does assume your USB stick has a sensible partition table on it).

  • Insert USB stick (and make sure USB micro B is not connected).
  • mkdir -p /dev/usbstick (using /dev is unusual but it should be a ramdisk so will be writeable)
  • mount /dev/sda1 /dev/usbstick
  • sudo dmesg > /dev/usbstick/dmesg.log
  • umount /dev/usbstick
  • sync