How to install apt on rpb(hikey960)

96boards

#22

Thank you for your help, I found that debian does not support WiFi, is there any way? Thank you


#23

I can use USB now, but I can not get online, what should I do to use wifi or wired network? Thanks. Here’s my output of ifconfig:
root@linaro-developer:~# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:4820 errors:0 dropped:0 overruns:0 frame:0
TX packets:4820 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:390360 (381.2 KiB) TX bytes:390360 (381.2 KiB)


#24

My problem has been solved, I can now use USB, wifi, usb network adapter。


#25

Hello, I have tried your method on my hikey960. It can boot successfully, but the usb host can’t work. And Is there any output on your screen? I only can recept the feedback by uart.


#26

I did this by replacing the boot in debian.img with the boot from the latest rpb.img (http://snapshots.linaro.org/reference-platform/embedded/morty/hikey960/latest/rpb/), then usb can be used.


#27

Thanks, I’ll try it.


#28

Now I got the GNU GRUB version 2.02 after boot. Have you encountered that problem?
And can you list all files and steps when you flash the image for Hikey960?
Thanks a lot!


#29

I refer to this link burning system (https://github.com/96boards-hikey/tools-images-hikey960/blob/master/build-from-source/README-ATF-UEFI-build-from-source.md):
After debian.img is prepared as I described above, run the following command:
$ sudo ./hikey_idt -c config -p / dev / ttyUSB1

UEFI running in recovery mode.
When prompt ‘.’ Is displayed on console, press hotkey ‘f’ in keyboard. Then Android fastboot app is running.

The timeout of prompt '. Is 10 seconds.

Update images.
$ sudo fastboot flash ptable prm_ptable.img
$ sudo fastboot flash xloader sec_xloader.img
$ sudo fastboot flash fastboot l-loader.bin
$ sudo fastboot flash fip fip.bin
$ sudo fastboot flash boot boot.img
$ sudo fastboot flash system debian.img

The above files except debian.img are from this link:
http://snapshots.linaro.org/reference-platform/embedded/morty/hikey960/latest/rpb/


#30

debian.img goes to the system partition, not cache.

sudo fastboot flash system debian.img


#31

It is my fault. Thank you


#33

Hello, I tried your method and also got stuck in the GRUB2. Would you like to tell me that the files (prm_ptable.img,sec_xloader.img,l-loader.bin,fip.bin and boot.img) are downloaded directly or compiled with the guidance in this link (https://github.com/96boards-hikey/tools-images-hikey960/blob/master/build-from-source/README-ATF-UEFI-build-from-source.md)

Thank you


#34

You can either download or build them. boot image (bootxxx.uefi.img) and rootfs image (rpb-xxx.rootfs.img.gz) are available at snapshot root directory [1] and ‘firmware’ images under bootloader dir [2].

[1] http://snapshots.linaro.org/reference-platform/embedded/morty/hikey960/latest/rpb
[2] http://snapshots.linaro.org/reference-platform/embedded/morty/hikey960/latest/rpb/bootloader/


#35

Thank you! After burning rpb.img, the system is booting successfully but cannot read my USB stick. What should I do to load USB stick?


#36

I assume this is a USB mass storage key, when plugin the key you should see the usb device detection with dmesg:

[   44.162311] usb 1-1.2: new high-speed USB device number 4 using xhci-hcd
[   44.287536] usb-storage 1-1.2:1.0: USB Mass Storage device detected
[   44.296592] scsi host1: usb-storage 1-1.2:1.0
[   45.355785]  sde: sde1

This means your USB key has been correctly enumerated and device present into /dev directory. You should then be able to mount one of the partitions (eg. sde1) and access the files.

$ mount /dev/sde1 /media

#37

However, my USB host still can’t work well after do these steps. I have tried the boot.img in latest rpb with the latest rpb.img also debian.img for hikey. And my USB disk’s LED was off.


#38

I have solved this problem by pulling out the UART. But can UART disable the USB interface?


#39

How do you replace the boot in debian.img?


#40

The debian.img and rpb.img are all sparse image, which means you need simg2img(https://github.com/anestisb/android-simg2img) to convert them.


#41

Your USB host is USB type-A r type-C otg? My USB type-A seemly can’t work. And I haven’t tried my type-c otg.


#42

Hi @why, I am able to boot into debian and have the same problem for wifi as you reported. Can you please share how were you able to solve it and connect to wifi. Thanks