How to enable Ethernet?

Dear all,

Now I am trying 96Boards Carrier Board and TB-96AIoT.
I installed linux successfully and typed ifconfig -a but ethernet is not show even when CONFIG_REALTEK_PHY is enabled on kernel config.

Could anybody tell me how to enable Ethernet?

Thank you.

Is it your own build or a prebuilt image? can you share a link to the kernel boot log.

Loic-san,
I apologize for the delay in replying to you.

With the prebuilt image, eth0 is found.
With the my own build, eth0 is not found.

To make the build, I just followed Rockchip Official User Guide and got files whose names are the same as ones of the prebuilt image.

Here is the dmesg output.
For this message, CONFIG_REALTEK_PHY is not enabled.

Thank you for your help.

Loic-san,

I found that device tree differs.
Since my target is rootfs, I decided to use prebuilt image except for rootfs, and ethernet works well with it.

Thank you

Maybe you have not download the related codes for TB-96AIOT.
You can refer to this link ( https://www.96boards.org/documentation/som/tb-96aiot/build/buildroot.md.html )to download codes for TB-96AIOT and develop it.

1 Like

Thank you, I tried it and Ethernet worked.