How to connect serial cable to debug boot time failures


We are facing some kernel boot issue. so can you please let us know the way to connect serial cable and see the boot logs.


Connect a usb serial cable/adapter from the board to your pc and follow the directions below:

[edited for accuracy]

“sudo apt-get install ser2net” is not working.
So tried downloading the source code of ser2net and compiled for arm64, but failed with below error.

/system/bin/sh: /data/ser2net: not executable: 64-bit ELF file

Can you please share the link to get built version of ser2net or steps to build it locally.

As I know “sudo apt-get install ser2net” is a ubuntu command, will this work for android also?


As I know “sudo apt-get install ser2net” is a ubuntu command, will this
work for android also?

Those commands are intended to be run on the host… If you modify UEFI
to issue debug messages then it may contain control codes that confuse
the terminal emulator (in other words is it recommending that you run
ser2net rather than minicom on the host to observe whats coming in via
the serial port).

PS Serial port for kernel console on hikey960 is LS-UART1 (a.k.a. UART6)
and uses 1.8v signalling. Do you have a 1.8v serial adapter?

Do you have a 1.8v serial adapter?

UART Serial - 96Boards - is this the one you are talking about? if so we will buy one.

You mean connecting TTL-232RG-VREG1V8-WE (1.8v serial adapter) to below PINs on 40 pin low speed expansion connector?
HiKey960 Signals PIN

Yes, the FTDI adapter should be fine.


I tried with FTDI adapter by connecting UART6_TXD 11, UART6_RXD 13 and GND to Tx, Rx, and GND of serial adapter.
I am seeing all junk characters, is there anything missed out here, please suggest.


I can only really say “works for me” (picocom -b 115200 /dev/ttyUSBx) and connected as shown here:



Thanks for the information.

I connected below pins to 1.8v adpater.
UART6_TXD - pin 11
UART6_RXD - pin 13
GND - pin 1

But from your picture I see that totally you have connected 5 wires, can you please tell what all pins you connected and what is that cable you are using and is there any setting to be done.

Even I tried using serial cable (DB9 cable), with that also I am seeing junk characters.


Only three wires of my TTL-232RG-VREG1V8-WE are connected (orange → pin 13, yellow → pin 11, nothing → pin 9, 7, 5, 3, black → pin 1). Sorry for the confusion in the photo, the extra wires were just part of the hookup wire I used to match genders. If you click on the photo and zoom in you’ll notice the remaining two connectors are just resting against the board (springiness in the wires) and are not connected to anything.

Thanks for your support, it worked.

But we have two boards, it works only in one board.
Both are same boards, only difference is the working board as default images which comes with the board, and for other board I have built and flashed.
Any idea is this hardware level issue or software?

Hi danielt,

can you please comment on this : SDIO devices with Hikey960 platform


Dear danlelt,

May I know where did get the acrylic case for HIKEY960? Thanks

I made it myself. The design files are here:

Am having a db9 rs232 USB to serial cable with 4 wires, (red, gree, black, white). Can i use this to get serial logs on hikey960 board ? can you please tell which wire should go to which slot in 40-pin LS extended ?

Basically i am trying to bootup zircon with this, but since no LEDs glowing, not sure the state until some shell interface is up

The signals on the board are 1.8v TTL and requires a 1.8v serial adapter.

An adapter with a DB9 connector is almost certain to be a much higher voltage (between 5v and 12v and with inverting buffers) and will damage the board.

can you please tell which wire should go to which slot in 40-pin LS extended ?

The pinout is here (but get a suitable adapter before hooking anything up):

Thank you very much.
I was about to connect the RS232 cable, Now would better purchase a serial adapter (would not wish to blow the device)

There are several mezzanine boards that have a built-in debug adapter.
I would suggest the “sensors” mezzanine: