HiKey960 and latest debian console question

With a fresh HiKey960, and the mezzanine, I’ve had a bit of an adventure getting debian loaded on.

While updating the firmware, I was getting Synchronous Exception at 0x0000000000000000 using the version 59 firmware that debian.org references as part of install. I tried version 85 as well which produced the same error message. I was able to get the version 85 debug version to install however.

I installed the latest debian snapshots off linaro.org, however on booting the device, minicom allows me to interact with the boatloader (ie I can scroll up and down from the choices of debian gnu/linux, advanced options etc, but choosing debian linux doesn’t result in a working console that I can input anything into. I see all the boot messages, example:

inaro-developer login: root (automatic login)

Last login: Thu Nov 3 17:16:44 UTC 2016 on ttyAMA6
Linux linaro-developer 4.19.5-hikey #26 SMP PREEMPT Sun Sep 8 01:23:41 UTC 2019 aarch64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
root@linaro-developer:~# [ 7.489428] wlcore: PHY firmware version: Rev
[ 7.629913] wlcore: firmware booted (Rev

the system just won’t accept any input. Any ideas?


You can get the latest firmware here: http://snapshots.linaro.org/reference-platform/components/uefi-staging/latest/hikey960/release/

This is what linked in our documentation page for Hikey960.

Make sure you have disabled hardware/software flow control in minicom. You can still access UEFI console with flow control but not the debian shell.


And WHAT mezzanine would that be?

UART Serial one, sorry I wasn’t clear on that bit.

Thanks Mani! It was hardware/software flow control off that made all the difference.

FWIW the “latest” firmware is #85 which the release version is what I was having trouble installing but like I said the debug version of #85 did install and works.