HiKey620: In recovery mode there is no ttyUSB devices available


#21

@danielt

Yes, I am running a custom kernel. Which didn’t include the CONFIG_USB_SERIAL_OPTION configuration.

Now I am trying to build and use a custom kernel on the board but there is a problem with some dependencies
with libssl-dev.

dpkg-buildpackage: host architecture arm64
dpkg-buildpackage: warning: debian/rules is not executable; fixing that
dpkg-source --before-build build
dpkg-checkbuilddeps: error: Unmet build dependencies: libssl-dev
dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting
dpkg-buildpackage: warning: (Use -d flag to override.)
…/scripts/package/Makefile:75: recipe for target ‘bindeb-pkg’ failed
make[3]: *** [bindeb-pkg] Error 3
/home/buildroot/hikey/linux/Makefile:1345: recipe for target ‘bindeb-pkg’ failed
make[2]: *** [bindeb-pkg] Error 2
Makefile:146: recipe for target ‘sub-make’ failed
make[1]: *** [sub-make] Error 2
Makefile:24: recipe for target ‘__sub-make’ failed
make: *** [__sub-make] Error 2


#22

Thanks… this came up late in this thread because it is unusual for a distro kernel to disable this feature. I just wanted to check we didn’t miss something.

For the ssl-dev problem this is a quirk of cross-building debian packages that we have not been able to reproduce (and could easily be a distro bug). Either way @Mani has propose a workaround):


#23

@danielt @arturp

Actually we should revert this commit: https://github.com/suihkulokki/linux/commit/609b507d299b8e59f2ceac95683f31f38a44efcb

Not sure why @suihkulokki added this.

-Mani


#24

/me feels the light bulb turn on…

So it worked when I tested it because I tested an upstream kernel :wink:


#25

@Mani

I have found this which solves the dependency problem

but now there is another issue

arch/arm64/Makefile:48: Detected assembler with broken .inst; disassembly will be unreliable
CHK include/config/kernel.release
/bin/bash ./scripts/package/builddeb
cp: cannot stat ‘System.map’: No such file or directory
scripts/package/Makefile:79: recipe for target ‘intdeb-pkg’ failed
make[4]: *** [intdeb-pkg] Error 1

do you know what is this about?


#26

Can you do a clean build? Something might have screwed up!

$ make clean distclean

Also it is good to check the compiler/binutils version you are using.