Hikey 960with DJI remote control


#1

Hello to everyone. I am new in this forum and i am a new users of Android hikey 960.
I have a problem. I am trying to plug a remote control of DJI on the board hikey 960, but when i plug it the board died. Does anyone could help me and explain me the reason? Have someone ever tried it?
I can succefully plug the DJI remote control in an Android smartphone and comunicate with my app through the AOA. Is there the AOA protocol in the ASOP of the hikey 960.
Thank you


#2

The Hikey960 supports USB host mode, so it’s doable. It would help if you could share log (logcat and serial output) to check what’s going wrong.


#3

Are you plugging it into the USB-C port? Or one of the USB-A ports?


#4

thank you for the answer. I succefully plug the remote control to hikey 960. it was a problem of usb control: when i plug the remote control to the otg port with the mouse on the usb port the hikey die. Now i have another problem: i thought that the problem was on the version of android, so i updated it to the last version that is Android Q. Unfortunately i found out after that my application has got sdk not supported in Android Q yet. How i can go back in the version of Android Oreo or Nougat? I have tried to install old work version from https://snapshots.linaro.org/96boards/hikey960/linaro/aosp-master/ (i have watched the good work on manifest) but i am still on android Q


#5

OTG doesn’t make sense in the context of USB-C. OTG is a concept used to provide host capabilities to devices with PERIPHERAL sockets, like mini or micro A. USB-C is dual purpose socket that is for both host AND peripheral.

The board does not die when you plug in a device to the USB-C. It simply switches the USB connection from the HUB to the USB-C socket, which means that any peripheral you have plugged into one of the USB-A sockets will be deactivated.

You should connect your remote control into one of the USB-A sockets if you have to use more than one USB device simultaneously.

Regarding older Android builds, the oldest snapshot is from March 2018, which is before Master was moved up to Q, so it will report itself as P.


#6

Tthank you for the answers. I can ony plug the remote control to the USB-C, cause it works only like that. About the Android builds: i have tried to install few of old version but when i check the version it says Q but the version kernel change correctly


#7

No, it does not have to work “that way”. If you can’t plug it into an A socket, then you just need to buy the correct WIRE.


#8

If I plug the remote controll of DJI with the correct wire in the USB A the board doesn’t open the dialog for choose the app to work with. If I connect it to the USB-C the board open the dialog and let me choose the app. This is ok, it’s not a problem. The problem is that the sdk DJI doesn’t work good with Android Q. I tried to install a lot of old version (i have check the good work on the manifest) but after the installation the screen is black (the green led is blinking). Do you know which is the default version of the board? i would like to go back to that