Help for Hikey970 beginner

sudo fastboot erase system will erase the system partition. When you will use sudo fastboot flash userdata hikey970-lebian9.img it will first erase the userdata partition and then flash the image to that partition. So don’t worry about erasing the ufs

Has not worked, the system has not loaded the login screen. I have returned to flash and still have the image but with the sdd12 with 4.6 g :frowning:

As I said, now that I have nothing configured, as I could delete all partitions and that the resized I left with the 64g?

edit. Maybe modify the image wrong, the image you were referring to was boot-hikey970.uefi.img or was it another?

Here in the link is the image which supports 25GB userspace

Follow the following steps:
Step 1:
Switch 1 : ON
Switch 2 : ON
Switch 3 : ON
Switch 4 : OFF

Step 2: Untar the Lebian Image

tar -xvzf hikey970-lebian-9.tar.gz
    cd hikey970-lebian-9

Step 3: Connecting Cables

Connect Type C USB cable to the host and board and make sure it is configured as ttyUSB0
Connect Power Adapter

Step 4: Run the following command to flash all the binaries


Step 5: Remove the power supply and turn on the switches

Switch 1 : ON
Switch 2 : OFF
Switch 3 : OFF
Switch 4 : OFF

Step 6: Booting your image

**Remove USB Type C cable (important) 	
Connect HDMI cable.
Connect the Power Adapter.	

NOTE: Plug the HDMI cable before powering up.HDMI hot plug may not work.


After booting resize the root file system by using: sudo resize2fs /dev/sdd15

I did not pluck after flash with configuration 1-0-1-0; The 1-1-1-0 does not recognize windows and when trying to flash Ubuntu (through virtual box) is not running, I’m not lucky :fearful:
You will not have the drivers of the board by chance?

In your ubuntu vm install android-tools-fastboot using apt. After that do the steps that I’ve written above after installing the image from the drive

Nothing I tried with the 18.04 and 16.04 LTS and uninstalling Modemmanager as it says in the instructions and I left KO flashing the image (always 1-0-1-0) because in 1-1-1-0 does not recognize the system Hikey :frowning:

Did you run recovery mentioned in post 20 ? Follow the steps in post 20. They work perfectly fine. The script automates all the steps and it can even recover a bricked board.

If that I did but in Windows does not recognize me the plate well and to load on VirtualBox I hang up when I flash the RFS system. Probe several times and nothing (in mode 1-1-1-0 as you said).
In mode 1-0-1-0 works well even in Windows, which is where I do and is faster.


How do you do resize2fs with “Hikey 970 Lebuntu”?
It seems rootfs is not on /dev/sdd15


I downloaded the image from the Lemaker’s site and I have already done the required changes to the image as well as the scripts. Although I didn’t test the image, Please try it out and let me know if it works.

Please flash the script Instructions to flash the script will be given in the flasing_guide.txt.

Google-Drive Link:

I have changed the root to sdd15 with Lebuntu, following these steps:

Step 1. Edit the grub.cfg in the boot image

sudo mkdir /mnt/boot-hikey970
sudo mount -o loop boot-hikey970.uefi.img /mnt/boot-hikey970
sudo nano /mnt/boot-hikey970/boot/grub/grub.cfg

Change sdd12 to sdd15 and gpt12 to gpt15.

sudo umount /mnt/boot-hikey970

Step 2. Edit the flash script
Change from

fastboot flash system leubuntu-16.04.img


fastboot flash userdata leubuntu-16.04.img

Step 3. Flash and reboot, use resize2fs to expand the partition

sudo resize2fs /dev/sdd15

Here is the boot image I changed:
Password: 75n8

Thanks a lot, I’ll try Again


Your boot code works with resize2fs.

Does any know OpenCL support on ubuntu image? When I run clinfo, the response says there is no OpenCL device. Any idea how to enable opencl?


The ubuntu image is missing the userspace drivers and hence, clinfo shows no platform found. I tried running clinfo on the debian image on the lemaker website and that works.


Is it possible to reuse opencl driver from Debian to Ubuntu?
If yes, how to do it?


Does anyone know how to set cpu clk? I have tried to adjust
/sys/devices/system/cpu/cpu4/cpufreq/scaling_max_freq to 1.84Ghz on core 0-3, but system keeps resetting to back to the lowest value, 509Mhz


Yes, it is possible. You need to copy the user space binaries and place it correctly in the rfs. Also you have to point to You can see how to use opencl for 960 to get more idea about it.

Is there any one who saw grub menus…

I installed leubuntu on hikey970.
It works well…

But the problem is no out put between booting and login(shunya).
I want to see and choose grub menuentry…

Is any one do that??

grub is visible on the serial console.

2 posts were split to a new topic: Stuck at in