HDMI supported resolutions

Hi,

is there any limitation on HDMI resolutions supported
Kernel - 4.14.96
File system - Debian

currently HDMI in 1920x1080 resolution mode. I am trying operate HDMI in 1600x900 resolution mode(from start -->preferences --> LXQt settings --> Monitor settings–>HDMI-1–>resolution–>select 1600x900) but resolution falling back to 1920x1080. Any idea on this?

@Loic

Thanks,
Arun

have you tried using xrandr directly to set the resolution?
I don’t run GNU on my db820c’s, but I have found the HDMI to be quite robust in AOSP. The monitors I typically have connected support all standard resolutions up to 1920x1080, with 1280x800 native resolution flagged in the monitor’s firmware as preferred. AOSP picks 1280x800.

@doitright
Thanks for the reply.
I am working with kernel-4.14.96 and Debian setup

tried with xrandr,
$xrandr --output HDMI-1 --mode 1600x900

not able to set this resolution. How to know list of supported resolutions for HDMI in the current setup?

Thanks,
Arun

I think you can just run xrandr without any outputs.

BTW to output 1600x900 the display device must be computer-monitor-like (e.g. DVI-D EDID). If the display is TV-like (e.g. HDMI EDIDI) then 1600x900 won’t be supported (HDMI devices simply don’t have a field to report whether or not they can run this video mode).

Thank you @danielt

$xrandr

Screen 0: minimum 320 x 200, current 2400 x 1080, maximum 65535 x 65535
DSI-1 connected 480x800+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
480x800 60.00*+
DSI-2 disconnected (normal left inverted right x axis y axis)
HDMI-1 connected primary 1920x1080+480+0 (normal left inverted right x axis y axis) 527mm x 296mm
1920x1080 60.00*+ 50.00 59.94
1600x900 60.00
1280x1024 75.02 60.02
1152x864 75.00
1280x720 60.00 50.00 59.94
1024x768 75.03 60.00
800x600 75.00 60.32
720x576 50.00
720x480 60.00 59.94
640x480 75.00 60.00 59.94
720x400 70.08

xrandr showing 1600x900 resolution with 60Hz is supported. If i try to operate in 1600x900 with 60Hz, HDMI falling back to current resolution(1920x1080). Is it expected behaviour?

Thanks,
Arun

You could try booting with drm.debug=0xff to see what is happening during the mode switch.