Getting I/O Errors all the time


#1

Hi!

I have generated a yocto / OE Image for the DB410c. I have flashed the Image with fastboot to emmc, and I also tried out to flash it to the sd card, using the wic tool to create an sd card image. Either way, I end up getting I/O errors on boot.

print_req_error: I/O error, dev mmcblk1, sector 269319
mmcblk1: error -84 transferring data, sector 269318, nr 2, cmd response 0x900, card status 0xc00

and stuff like this. It ends up that the partition get set ro. I can run fsck, which fixes some errors. Second run, fsck says everything is nice. When I reboot, I end up in the same situation. I tried this now on two boards, therefore, I would rule out a hardware problem…

Any hints?! Boards came with Windows IoT on them. When using fastboot, I flashed bootloaders like in the howtos for Linux emmc…

Regards


#2

We have a known issue with some UHS SDCARDs (SDR104) on DB410C. You can either use a different SDCARD or if familiar with yocto, apply a patch [1] on top of the Linux kernel.

[1] https://fileserver.linaro.org/owncloud/index.php/s/X17WdjYeEw8tncU


#3

Hi Loic!

Thanks for the hint! I was getting desperate. I know my way around yocto, so I can apply the patch.

Do you know if it is possible to use a vanilla kernel with the db410c, or is the patchset rather large? Also, has anyone tried out to use u-boot as APPL bootloader?

Regards,

Matthias


#4

Yes, It’s supposed to work. The QCOM landing team has a branch (integration-linux-qcomlt) on which they continuously rebase their changes on top of Linux master. (note that previously mentioned patch is not yet in vanilla kernel). The recommended stable kernel for DB410C is however 4.14.

Not sure about the status here, you can, however, load u-boot from the bootloader (LK).