Flashing DB845c RB3 with Android-12 T

  1. trying to flash my DragonBoard845c - RB3 QC Robotics Dev kit with AOSP Android-12 T and simply can not get it to work - I started here Using Reference Boards  |  Android Open Source Project - I built my images no worries then "Installing local images Boot db845c into fastboot mode (see DragonBoard Recovery). Run following command: ./device/linaro/dragonboard/installer/db845c/flash-all-aosp.sh - when I run this script it fails when trying to flash vendor_boot.img. I can not find vendor_boot.img anywhere and can find no instructions to build it - where can I get this file? after this error the board is soft-bricked and I must put it into EDL mode and run ./device/linaro/dragonboard/installer/db845c/recovery.sh - to be able to get back to fastboot mode. I have tried going to AOSP/db845c - Linaro Wiki and trying Flash downloaded AOSP images by running following commands, while booted in fastboot mode: 1 fastboot flash userdata userdata.img 2 fastboot flash super super.img 3 fastboot flash boot boot.img - but this simply bricks it again. Can some one please help me to flash this board with Android 12 T? (edited)

  2. [3:45 PM]

Support for the AOSP reference boards is maintained only for the latest AOSP mainline. Fixes are not backported to Android release branches so if you have deliberately wound back to the release branches than there’s a fair chance you are building a branch that doesn’t work on DB845C.

Does a mainline build work for you?

This error is harmless. vendor_boot.img only exists if you enable a non-standard build mode so this being absent should not be the cause of problems booting the board.

I am using the mainline branch -

  1. Download the Android source tree:
    repo init -u platform/manifest - Git at Google -b master
    repo sync -j8
  2. Build:
    . ./build/envsetup.sh
    lunch db845c-userdebug
    make -j24

when I run the flash-all-aosp.sh script is says it works and it is Rebooting - but it doesnt. It ends up with the blue led and the green led lit and steady with no fastboot device or edl mode. When I try to reboot it it goes directly to this state again. I am forced to put it into edl mode and run the recovery.sh script to get back to fastboot

@danielt thanks for the help - I was able to run the recovery.sh and then the flash-all-asop.sh and it boots and runs the AOSP mainline build