[fixed] Cannot flash boot partition with fastboot

Hello there,

I recently started to play around with the db410c. I was able to build the AOSP master with few patches that I found around on Linaro repo. Anyways, I have some problems understanding the bootloaders components / partitions while debugging the problem.

From the documentation it seems you can recover partition table and bootloaders using qdl tool, from this link I got the packages (https://releases.linaro.org/96boards/dragonboard410c/linaro/rescue/latest/). I tried the AOSP package but it does not contain the prog_emmc_firehose_8916.mbn flasher and if I use the same flasher on AOSP package it does not work.
So, using the linux package I was able to recover the board and start it in fastboot. Now, even if I flash again the partition table with the aosp partition table I cannot flash the boot partition. When I use flastboot flash boot boot.img it keeps saying:

fastboot: error: Couldn’t parse partition size ‘0x’.

while if I just use the fastboot boot boot.img I am able to run Android 10. Do you have any idea about it?

This is what I can see from the UART:
Format: Log Type - Time(microsec) - Message - Optional Info
Log Type: B - Since Boot(Power On Reset), D - Delta, S - Statistic
S - Boot Config, 0x000002e1
S - Core 0 Frequency, 0 MHz
B - 1545 - PBL, Start
B - 3491 - bootable_media_detect_entry, Start
B - 102094 - bootable_media_detect_success, Start
B - 102099 - elf_loader_entry, Start
B - 103602 - auth_hash_seg_entry, Start
B - 103813 - auth_hash_seg_exit, Start
B - 118883 - elf_segs_hash_verify_entry, Start
B - 179113 - PBL, End
B - 151737 - SBL1, Start
B - 202977 - pm_device_init, Start
D - 14274 - pm_device_init, Delta
B - 217587 - boot_flash_init, Start
D - 30 - boot_flash_init, Delta
B - 221613 - boot_config_data_table_init, Start
D - 24613 - boot_config_data_table_init, Delta - (452 Bytes)
B - 250801 - CDT version:3,Platform ID:24,Major ID:1,Minor ID:0,Subtype:0
B - 257023 - sbl1_ddr_set_params, Start
B - 260836 - cpr_init, Start
D - 0 - cpr_init, Delta
B - 266448 - Pre_DDR_clock_init, Start
D - 213 - Pre_DDR_clock_init, Delta
D - 0 - sbl1_ddr_set_params, Delta
B - 279044 - pm_driver_init, Start
D - 3477 - pm_driver_init, Delta
B - 291122 - SBC platform detected: XO_ADJ_FINE = 0x20
B - 291153 - clock_init, Start
D - 30 - clock_init, Delta
B - 306067 - Image Load, Start
B - 327417 - Error code 3038 at boot_elf_loader.c Line 334

Sounds like a messed up partition table. Did you install AOSP using the flash-all-aosp.sh in the installer directory (which sets up the partition table also)? Or are you trying to just flash the partitions manually?

I’ve tried as well. The weird thing is that when the script try to do the erase, it succeed.

fastboot erase boot
Erasing ‘boot’ OKAY [ 0.029s]
Finished. Total time: 0.038s

but the flash does not work. The boot.img size created is 12M so should be fine since the default partition size is 32M.

users 12M Jul 29 21:38 boot.img

BTW, there is any way to ‘print’ the partition table currently flashed? for example using fastboot?

Not from fastboot that I’m aware of. You should be able to read the partition table from the OS after booting. And for that matter, since you are able to fastboot boot, you should be able to write it with dd.

thanks for the suggestion. Somehow I was able to fix just using the fastboot that is available within the sdk. With the fastboot that is built while building AOSP I still have the issue.