Fastboot does not work, QDL return NAK when try flash

I have new DB 820c.
Try to fastboot on it to install AOSP
Fastboot seems not working.
I have tried qdl:
I have latest qdl:
commit 13681fcb359c9f9c32a17a91d3dd20df2e413b6d (HEAD → master, origin/master, origin/HEAD)
Author: Bjorn Andersson
Date: Thu Apr 29 10:25:55 2021 -0500

I have

Run it as follows

sudo …/…/…/qdl/qdl prog_ufs_firehose_8996_ddr.elf rawprogram0.xml rawprogram1.xml rawprogram2.xml rawprogram3.xml rawprogram4.xml rawprogram5.xml patch0.xml patch1.xml patch2.xml patch3.xml patch4.xml patch5.xml

And get output
HELLO version: 0x2 compatible: 0x1 max_len: 1024 mode: 0
READ64 image: 13 offset: 0x0 length: 0x40

READ64 image: 13 offset: 0x6d1b0 length: 0xff4
END OF IMAGE image: 13 status: 0
DONE status: 1
FIREHOSE READ: <?xml version="1.0" encoding="UTF-8" ?>

LOG: Binary build date: Jul 15 2016 @ 04:52:20
FIREHOSE READ: <?xml version="1.0" encoding="UTF-8" ?>

LOG: Chip serial num: 4053131795 (0xf195e213)
FIREHOSE READ: <?xml version="1.0" encoding="UTF-8" ?>

LOG: Supported Functions: program configure nop firmwarewrite patch setbootablestoragedrive ufs emmc power benchmark read getstorageinfo getsha256digest erase peek poke
qdl: firehose operation timed out
FIREHOSE WRITE: <?xml version="1.0"?>

FIREHOSE READ: <?xml version="1.0" encoding="UTF-8" ?>

LOG: **WARNING Ignoring Unrecognized tag ‘?xml’
FIREHOSE READ: <?xml version="1.0" encoding="UTF-8" ?>

(I have tied different MaxPayloadSizeToTargetInBytes )

What this NAK means?

What can I do?

Shall I do step for UFS provisioning?

Or shall I try first SD card option?

I am using most recent bootloader package from the

I have noticed that

Chip serial num: 

Returns sometimes different value.

Maybe there some issue with SoC itself?

Seems I have same issue with another board.

This one started some linux OS.
But after I have tried to get to fastboot there is same issue.

It should NOT be necessary for you to use QDL to switch over to AOSP. This is something you should be able to do with just fastboot, which should be working as the board is delivered. What exactly happens when you try to go into fastboot mode on the board? I’d like you to copy/paste the actual output from the db820c’s UART, as well as the console output from your workstation during the attempt to install AOSP using the “” script.

This will help to see what is actually going on with your board.

You have not explained this “same issue”. You skipped that and went straight to QDL.

Importunately I don’t have UART connector module.
Issue is like there is not fastboot device in output of

fastboot devices

also lsusb shows nothing;

Ok, before you go any further and risk doing some damage to something or bashing your head against a wall needlessly, GET ONE. Any 1.8v USB-UART dongle will do the job:

Set the dongle to 1.8v, hook its TX pin to LS header pin 13, RX to pin 11, and GND to pin 1, then run “screen /dev/ttyXXXX 115200” to get your console output.

Actually I try to find one, (look like I need to purchase one)
But I have only usb-uart which requires VREF,
can I use 1V8 as vref?

I gave you a link to one. You do not need vref unless the dongle doesn’t have its own vref.

But I already have one. And that requires vref.
Will it work?

I have a hard time knowing what you mean when you say the opposite. Does what you have support 1.8v? Most do NOT. If it does, then go ahead and use it.

Edit: If what you have does NOT support 1.8v, then you might still be able to use it – attach RX to pin 11, GND to pin 1, and DO NOT CONNECT TX!!!

That was what I was curious about, if I can use one I have, or I need to get another one.

Thanks for hint with RX.

Its obviously hard for me to assess your equipment without knowing what it is. You’ll have to judge it for yourself.

Pin 35 on the low speed connector should be providing a 1V8 reference voltage you can use.

Check with a multi-meter first though since some of the 96Boards need working software to engage the reference voltage (I don’t think this list includes DB820C but checking with a multi-meter now will save head scratching later if I am wrong).