Fail to build aosp for hikey970

I was following https://www.96boards.org/documentation/consumer/hikey/hikey970/build/aosp.md.html to build image for hikey970 , but encountered some problems when running ‘mm -j 16’.


“fs_config_generator.py fsconfig: error: argument --all-partitions: expected one argument”

I googled the error, very few search results, and none could help on the error.
Edit 1 : fixed by adding two ‘’ to out/build-hikey970.ninja.

continue to mm -j 16
then error about “hostapd (token) error…”

fixed by merge the following patch.
https://android-git.linaro.org/device/linaro/dragonboard410c.git/commit/?h=dragonboard&id=dbe30cae1ef227860089e1840aeb1cd140c0003a

Then continue
git clone https://github.com/96boards-hikey/tools-images-hikey970.git
$ cd tools-images-hiKey970
there are build_kernel.sh, I copied the file to aosp root dir, and executed:
./build_kernel.sh

Then continue, burn system/boot/cache/userdata images, but boot still failed with the last part log,
"
[ 18.928587] [I/hisi_pd] PE:TYPE-C Only Charger!
[ 18.933267] [E/hisi_pd] pd_dpm_handle_pe_event:!!!,event=3,+++
[ 18.939115] [I/hisi_pd] pd_dpm_report_pd_sink_vbus : Sink 5000 mV, 500 mA
[ 18.945910] [E/hisi_pd] pd_dpm_vbus_notifier_call: pd_dpm_vbus_notifier_call!!!,++++
[ 18.953676] [E/hisi_pd] pd_dpm_handle_pe_event:!!!,event=8,+++
[ 72.147111] random: crng init done
"

any way to fix this ?

Sorry not adding any help but asking for it since you solved one problem i am having right now.

“fs_config_generator.py fsconfig: error: argument --all-partitions: expected one argument”

You said you solved this by
“Edit 1 : fixed by adding two ‘’ to out/build-hikey970.ninja.”
Can you please tell me where in the file ?

BTW, have you compiled Hikey970 AOSP with latest AOSP Master branch ? that is Android Q.
Thanks in Advance.

to fix partition errors, I edited out/build-hikey970.ninja, it is a big file and you could search ‘all-part’, then added two ‘’ after the command.
yes, I compiled with the latest mater branch successfully, however, it does not boot 970.