Facing crash issues in Kwin-x11 5.14.5

Hi,
@danielt @ndec

I’m working with Kwin 5.14.5 and the latest Debian image. The display crashes/blanks out and logouts frequently, thus closing all the previous sessions. What may be the cause for this and how can I fix this?

This is the only log I get when the display blanks out.
[ 1544.449229] msm 900000.mdss: vblank time out, crtc=0
[ 1544.544976] msm 900000.mdss: vblank time out, crtc=0
[ 1544.600953] msm 900000.mdss: vblank time out, crtc=0
[ 1544.655789] msm 900000.mdss: vblank time out, crtc=0
[ 1544.732986] msm 900000.mdss: vblank time out, crtc=0
[ 1544.853020] msm 900000.mdss: vblank time out, crtc=0
[ 1545.060999] msm 900000.mdss: vblank time out, crtc=0
[ 1545.136983] msm 900000.mdss: vblank time out, crtc=0
[ 1545.205013] msm 900000.mdss: vblank time out, crtc=0

Thanks,
Naveena

Which image is it ? 19.01 release or a snapshot?

I think it’s related to https://bugs.96boards.org/show_bug.cgi?id=843
Would be nice to identify from which image problem started, though the problem is probably related to a mesa update.

I’m using the snapshot 384 from the following link:
https://snapshots.linaro.org/96boards/dragonboard820c/linaro/debian/384/

Previously, when I was using snapshot 228, the kwin version was 5.13.5 and I didn’t get this crash issue. With the snapshot 384, I face this issue and the kwin version here is 5.14.5.

@Loic
I am facing the same issue whileinstalling the qt-creator.
Initially the kwin version was 5.13.5, but while installing qt-creator using the command

apt-get install qtcreator

, it removed kwin package. Then I had to install the kwin again, and that brought the latest version of kwin (5.14.5) in. But then the window manager started crashing randomly.On crash the board goes to login screen and from there i will have to start the whole session again.

What is the fix for it? Is there a way to install kwin 5.13.5 after installing qt?

@Loic

Any update on this?

Could you please add your observation/input to the bug: https://bugs.96boards.org/show_bug.cgi?id=837, can you try downgrade mesa to the 228 snapshot version?