Enabling the camera sensor of the On-Camera Mezzanine (AR1337 sensor)

Hello,
I have been searching for documentation on how to enable the AR1337 sensor for Debian on Dragonboard410C, but apart from seeing a few mentions that people have gotten it working
I haven’t found any info as to the process of doing so.

My assumption is that I will have to create the camera driver (not found in the kernel, and I haven’t found it anywhere else either), and enable it in the dtsi file.

Does anyone have further info/suggestions on getting this working that they’re willing to share? Anything is greatly appreciated.

On-Camera Mezzanine (AR1337): https://www.96boards.org/product/on-camera/

Thanks

The driver certainly exists, but is not upstream, I think you should contact MMSolutions (www.mm-sol.com) or arrow to get information about software components. I would also be interested about the way to enable it.

So far MM-Solutions has not been responding, and the people at Arrow I talked to don’t seem to have any more information on the mezzanine.

I did find this though: https://git.linaro.org/people/manivannan.sadhasivam/96b-common.git/commit/?h=ar1337

However, using this driver results in the following error (I changed it to I2C address 0x3b here in the dtsi, but originally used 0x36):

My assumption is that either the I2C bus or address used in the dtsi file is incorrect, but I’m new to Dragonboard so I’m not really sure.

I2Cdetect gives me this:

Busses 0 and 1 have no devices on them, cannot check bus 4 (does not support detection commands), and there appears to be three devices on bus 3?

I tried changing the bus to 3 and the I2C address to each of those, in addition to the 0x36 address originally used in the commit. I also tried 0x36 on bus 4.

It is probably obvious that I’m a bit lost on how to go about this. Anything that might point me in the right direction for figuring this out would be greatly appreciated!

Which release/kernel are you running?

The camera is probably (I neither have the board nor the schematics) behind the CCI I2C bus (i2c-4), but anyway, if the camera requests a power-on gpio, you’ll not be able to detect it, except if you manually setup the gpio.

@Mani, is the driver supposed to work? any plan to upstream that driver?

I’m using the 4.14.96 kernel. I downloaded the kernel from that commit, and compiled that so that there wouldn’t be any difference.

Ok, I’ll try looking into that a bit more and see what I can find.