DragonBoard410c + AISTAR VISION MIPI adapter + RaspberryPiCamer

Hello.
I would like to connect RaspberryPiCamera with Dragoboard 410c + AISTAR VISION MIPI adapter v2.0 or v2.1 Mezzanine. Has anyone succeeded?
I have RaspberryPiCamera V1.3 and V2.1.
My version of Debian is 19.01.

@mochimasa Last time when I tried Rpi camera v1.3 with MIPI adapter v2.0, got some timeout issue. I think the camera sensor never transferred any frames but the initializations were fine.

Are you having similar or other issues?

Hi Mani,

Thank you for the information.
I am about to start.

Please tell me that it is initializing.
How do you change apq8016-sbc.dtsi? Should I change the CCI address and sensor name?
Did you use ov5647.c as the driver source?

As picture is out with ov 5645,
I was thinking about changing ov5645 little by little.

@mochimasa

You can refer this commit: https://git.linaro.org/people/manivannan.sadhasivam/96b-common.git/commit/?h=db410c_camera

For using Rpi camera, you can refer the MIPI adapter user manual (v2.0/v2.1): https://github.com/Kevin-WSCU/96Boards-Camera

Hi Mani,

Thank you for the information.
I will study tomorrow and give it a try

Hello, Mani

I will report today’s work.

I built the source I was taught and tried it.

As ov5647.ko was not output, I added a line of

CONFIG_VIDEO_OV5647 = m

to “arch/arm64/configs/defconfig”.

I wrote boot-db410c.img to Dragonboard 410c, transferred the module, installed Raspberry Pi Camera Rev 1.3, and started it.

There was an error in dmesg.

[10.023169] ov 5647: probe of 4-0036 failed with error -5

I connected the power again by connecting pins 1 and 2 and pins 3 and 4 of J15 on the MIPI board.
There are no errors.

$ sudo media-ctl -d / dev / media0 -p
The ov5647 information came out.

Please let me know if you know the setting of media-ctl which will output the picture with ov5647.

The connection of the jumper pins is as shown in the picture.

1 Like

@mochimasa Glad to hear that you have interfaced the camera with db410c. IIRC, below is the media link setup I used before:

sudo media-ctl -d /dev/media0 -l '"msm_csiphy0":1->"msm_csid0":0[1],"msm_csid0":1->"msm_ispif0":0[1],"msm_ispif0":1->"msm_vfe0_rdi0":0[1]'

sudo media-ctl -d /dev/media0 -V '"ov5647 4-0036":0[fmt:SBGGR8_1X8/640x480 field:none],"msm_csiphy0":0[fmt:SBGGR8_1X8/640x480 field:none],"msm_csid0":0[fmt:SBGGR8_1X8/640x480 field:none],"msm_ispif0":0[fmt:SBGGR8_1X8/640x480 field:none],"msm_vfe0_rdi0":0[fmt:SBGGR8_1X8/640x480 field:none]'

And finally used Yavta[1] tool to capture frames:

$ yavta -B capture-mplane -c10 --requeue-last -f SBGGR8 -s 640x480 /dev/video0 -F

As you can see, I’ve used raw bayer8 format with resolution of 640x480, default settings supported by the mainline ov5647 driver. With this setting, I got vfe timeouts.

Let me know what you are getting :slight_smile:

-Mani

[1] https://github.com/fastr/yavta