Dragonboard not working after failed linux instalation


#1

Hi, My board stoped working after I attempt to install ubuntu core.

Here what couse the problem.

  1. I successfully installed debian img using flashboot process
  2. I mounted a usb driver in the board, downloaded the ubuntu core img
  3. From the board I tried to install ubuntu img in the pen drive into emmc using
    sudu dd if=usb ubuntu img of=emmc disk bs=2m
  4. when I reboot it had a crash and memory dump and now I can’t boot the board anymore.

There is any way I can fix?


#2

hey,

as far as I know, the released Ubuntu core image are not meant to be flashed to eMMC. They are SD card images. You should dd the downloaded image on an SD card , on your PC, then you can boot the SD card from the board (using SD boot).

What you ended up doing with #3 is that you erased the eMMC with the content of the SD image, and that’s why it won’t boot. To fix that, you need to reinstall Linux/Debian using the SD rescue/recovery method (documented in the user guide).


#3

Hi ndec, thank you for your response.

Here what I have done but didn’t work.

  1. downloaded db410c_sd_rescue.img.
  2. sudo dd if=db410c_sd_rescue.img. of=/dev/disk2 bs=2m
  3. Set board switch to 0-1-0-0
  4. powered on.

Nothing happened, I saw a blue led blinked once and nothing more. the green led never turned on.
any advices?


#4

ouch. this is not expected. I have seen one other similar report in the past, where the ‘rescue’ image can’t rescue. I think it is a bug in the bootloader that we put on the rescue image… i am afraid you might be hitting it.

any chance you can hook up to UART/serial console to see if you get anything on the debug console?

well, now that there is a method to reproduce this issue, i will try to brick my board in the same way you bricked yours… hopefully i can then fix the SD rescue image… but it will take some time…

in the mean time, if you can’t get UART, then can you please try one more thing: so install debian/linux using the SD install method (also in the user guide). Unlike the rescue image, the SD install image contains the entire Linux image to be flashed, and it runs a graphical installer on the SD card.


#5

Hi ndec,

I don’t have access to a UART/Serial. But I will try to install the debian/linux.

I als I was trying to replicate this method in this post when I bricked my board

Thank you for your help

best

Jorge


#6

thanks for the link. for sure I confirm that these instructions won’t work on DB410c. It is certainly possible to get it installed on eMMC , but it would require a few more steps…


#7

Hi ndec,

I was finally able to bring my board back to life.
I tried dragonboard410c_sdcard_install_debian-144.img. But it didn’t work.
than I tried dragonboard410c_sdcard_install_debian-110.img, but also didn’t work
than dragonboard410c_sdcard_install_ubuntu-102, didn’t work either.

then I used the qualcomm dragonboard410c_sdcard_install_android-99.img and I was able to install to the
eMMC, than using fastboot I was able to install the latest debian img.

It would be nice to be able to install the ubuntu core into the eMMC

Thank you for your help!!


#8

thanks for the details… I have opened https://bugs.96boards.org/show_bug.cgi?id=466 to keep track of any further progress on our side.

regarding ubuntu core in eMMC, this is a request that should be done to Canonical/Ubuntu, we are not involved there.


#9

Hi @ndec,

I may have a same problem you mentioned above, i.e. the ‘rescue’ image can’t rescue
I did according to the instructions here, but when I powered the board, no any led was lighted.

I also tried the way @jbastosn said in which he has booted up his board, i.e. using “qualcomm dragonboard410c_sdcard_install_android-99.img” to install Dragon, but it didn’t work either, there was only one blue led (BT/WIFI) blinked once when I powered on the board with the sd card inserted into slot.

I got this dragon at SFO15, it worked then, but I haven’t used it for a long time.

Is my Dragon board bad? If not, could you give me some suggestion, what should I do to retrieve my board?


#10

i am working on a bootloader upgrade that will include:

  1. newer SBL (proprietary bootloader)
  2. newer LK (open source)

For #1 I am waiting for QC to release it, which should be in the very next few days. We will see if the new resulting images will fix this situation or not. If not, i will need to debug further.


#11

Hi @ndec,

I also encountered the similar issue and cannot boot my board from SD, is there any update for this issue?


#12

hi @tsanchao, i am sorry , but no update on this issue so far.