DragonBoard KeyBoard/Mouse and micro USB not responding


#1

I was flashing Android with sdCard, then Linux Linaro with Fastboot. Till there all fine. I flash Windows 10 IoT and all the flash process went fine but at this point the system just ignore my mouse and kboard.
Since the USB was not working I was unable to reflash by sdcard (need the mouse to accept the boot)
No way to get connect with PC and fastboot.
Reflash by using Rescue, and fastboot Linux again. Linaro is here. No mouse/kboard.
Still no USB… :frowning:

What else can I try? Is the USB dead?


#2

Hi jean-marc,

Have you tried removing the microUSB cable first? See below for more info:
http://www.96boards.org/forums/topic/android-on-96boards-faq/#post-14462


#3

Yes I did.
Is like the DragonBoard has lost its own USB drivers.
Thanks for the help.


#4

Anyone with some ideas?
Am I the only one having problems with the USB???
I get stuck here.
Is it possible to load the DragonBoard USB drivers by flashing them?
Anyone from Qualcom could answer?

Thank you in advance for any help


#5

For more info: Just flashed Android with fastboot. OK Android booting.
I am becoming an expert in booting this board :frowning:
Still no mouse/kboard.

Anyone could tell me if I have to trash my board???

Got more info, ADB is also functioning and can connect to LogCat.
get a lots of those messages:

“E/USB_UICC: Timeout! No signal received. Retry num = 23”

Does this has something to do with my USB problem??

Thank you for helping.


#6

Hi @jmjobin,

I am not completely sure what happening to your USB port but it could be software problem or hardware problem.

Do you mind attaching all the dmesg log here?

Also do you have multimeter? If you have one I am a bit curious of the voltage on the USB Type A connector between pin1 5V and pin4 GRD.


#7

Hi @jmjobin,

I came up with other idea.

Please type bellow from you command line.
$ lsusb

If the hardware is working then it should show at least following two lines.


Bus 001 Device 002: ID 0424:2513 Standard Microsystems Corp. 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

If it does not show the above lines, I have to assume your board is damaged somehow.


#8

Dear Akira,
I just read my mail today. I am away these days UNFORTUNATLY :frowning: I am eager to try what you mentioned. I have also the possibility to check the voltage. I did not try this yet. Great ideas. Will do it asap e let you know.

Thank you again.
Jean-Marc


#9

Dear Akira I was able quick to make these tests.
The USB has 5.2-5.1 vdc which sounds nice to me. Measured with and without kboard/mouse inserted.
For the command $lsusb from my Android I get /system/bin/sh: lsusb: not found
I am not a Linux expert…

Jean-Marc


#10

Hi @jmjobin,

I did not know you were running Android. The “lsusb” command is not in Android.

One more thing you could try for your USB connector issue is that installing the latest member Debian 16.04 release and try the “lsusb” again.

From SD card:
https://github.com/96boards/documentation/wiki/DragonBoard%E2%84%A2-410c-Linaro-Debian-Download#your-build-choice

From fastboot:
https://github.com/96boards/documentation/wiki/DragonBoard%E2%84%A2-410c-Linaro-Debian-Download#your-build-choice-1


#11

Akira, thank you, will do it and thank you for the follow up.
I have a new information and question before making the Debian reflash. Will do it in the next days…

In Fastboot mode (I mean when I push the (-) and power ON) the mouse lit and seems to work. (I am in fastboot I can see only the light coming and going stronger when moving)
If I do not flash and power OFF/ON without the fastboot mode (no pushing on the (-) and let Android comes up) the mouse stays OFF!!! It must be software…

Another question before going on, you suggest me to use the SD card (see your above comment with the 2 links) but how can I use the SD card without kboard/mouse? Is there a way? Because the system ask you you you want to boot and you need to answer by either the kboard or mouse. Or is there a way to bypass the question?


#12

Hi All,
I too had the same issue where my USB and key Board is not responding.
I had also few other observations.

  1. Some times mouse gets power and some times it is not . As my mouse is optical one, sometimes I dont see any LED glowing.

  2. When I tried SD Boot I see my mouse sometimes responding, Mouse moves but click does not get registered.

  3. Then I realized that after I press 10 15 clicks my click got registered and I could install Ubuntu Linux.

  4. Now my mouse is not responding but when I looked at the kernel boot log I observed the following… (could not exactly note the error, taken the error from someone else’s post)

`usb 1-5: device descriptor read/64, error -32 usb 1-5: new high speed USB device using ehci_hcd and address 6 usb 1-5: device not accepting address 6, error -32`

I will be glad to debug this issue with some help…
Thanks
Mishradk


#13

Hi @jmjobin,

Thank you for joining the Open Hours this week.

Yes, you are right, if the usb-mouse is not working, the installing Debian from SD card is not going to work.


#14

Hi @mishradk,

Thank you for sharing your error messages.

We are also trying to reproduce the situation on the usb-mouse and keyboard.

We will inform you when we see the error messages you have posted and come up with an idea what might be happening.

The only thing I could think of right now is the difference with the AC adapters, but not really sure.


#15

Hi Akira,
I tried to get one more DB410C and realized that its working fine with my power supply.
In fact this power-supply was provided to me by Arrow… :frowning:

I dont have a serial adapter to take linux kernel boot images. Yesterday I had checked with Seed Studio and realized that the adapter board is not in stock.

If anyone assists me in a circuit diagram, I will try to assemble a small serial cable myself.

At least this device should work once… so that I can enable ssh and continue working in a headless way.

Could you tell me how do I check if there is any power issue ?
Or is there any other way to debug this issue ?


#16

Dear Akira,
I ran in other problems. I think my board died. No more boot, even so I did not flash anything new.
The power is ON, I checked.
Anyway, I just ordered a new board and I would recommend to any one the use of the correct plug for the supply.
I did not find one from my suppliers and my replacement could have done several bad contacts sometimes.
That is the only explanation that would lead for this strange behaviour.