DragonBoard 410C wont start

96boards

#1

Hello. I have a problem with my dragonboard410c. It wont start, i can see only Bluetooth indication led for less then one second and then nothing. I am using 12V 2A power adapter and full hd hdmi monitor, also i have android operating system booted on the board. Thanks for answers.


#2

Can you try debian sdcard images from here http://snapshots.linaro.org/96boards/dragonboard410c/linaro/debian/latest/


#3

I am sorry but i cant because my board cant enter boot mode. Thanks for answer.


#4

I would suggest to check your power supply connector, must be 4.75mm.
Very often a bad contact might generate the problem.

DragonBoard 410C - (Almost) No sign of life out of the box.


#5

Ok i will try. At the moment i am using powering method from this side
(https://www.google.cz/amp/s/anwaarullah.wordpress.com/2016/09/09/externally-powering-the-dragonboard-410c-syedtips-1/amp/) so i will try and reply. Than you.


#6

What happened to the LED lights when you tried this?


#7

I cant try because when i power the board only bt indication led lights up and then nothing more happen. I tried different monitors and power sources and i cant see any screen. Thanks for answer and soryy for my english


#8

So my answer is nothing


#9

Sorry to push on this but I’m still not 100% sure what you mean here.

Do you mean you burned an SD card, set the DIP switches and tried it? Which guide did you follow?


#10

I switch on sd card boot and insert card with loaded debian then i pluged in hdmi cable. Finally i powerd the board


#11

(https://www.96boards.org/documentation/consumer/dragonboard410c/installation/) this is link i followed. But personally i do not thing its a software issue because the board should always display something when its properlly connected (i think). Also thanks for answer and sorry for my bad english.


#12

It would be good to confirm what happens to the LEDs before we assume the board is broken. The installer images and debian images set an LED flashing as soon as the kernel starts (this is different to the Android image).

However if the LEDs don’t come on and you are sure you followed the steps correctly then I’m afraid your board is probably dead.

Note that https://www.96boards.org/documentation/consumer/dragonboard410c/installation/ is a menu for five different sets of install instructions, so I cannot really comment on the install steps. However if you were following the Windows instructions (https://www.96boards.org/documentation/consumer/dragonboard410c/installation/windows-sd.md.html ) then it might be worth trying again using https://resin.io/ instead (I believe many people have problems with selecting the right driver letter when using Win32DiskImager). This is unlikely to work but is a sensible last test before discarding the board (or returning to vendor is it arrived broken).