Dragonboard 410C USB issue

One of our customer using DragaonBoard410C for his application.

  1. They are connecting USB camera on USB port J2/J3, its working fine.
  2. They are connecting USB Modem based on Quectel EC20 on either USB port J2/J3, its working fine.
  3. But when they tried to connect both together, The issue reported is that while camera is connected to J2 and modem is connected to J3, the sanpdragon is unable to stream frames.
  4. And then tried using a USB Hub with APQ8016 and at hub they has interfaced one camera and EC20 4G Modem. So While both Power On then Camera is not Streaming while Modem is Working Fine. After Evaluating at our end we had interfaced Modem and Camera at usb hub with OS then both running fine, So the conclusion may be because of Bandwidth issue of Processor that doesn’t support both the thing Simultaneously.

Need your support on the same.

Debian Stretch|

|Kernel version|4.9.56-linaro-lt-qcom|

|Kernel toolchain|gcc-linaro-6.3.1-2017.02-x86_64_aarch64-linux-gnu.tar.xz|

Vageesh K M

A post was merged into an existing topic: Unable to stream data from a UVC camera as soon as a plug LTE modem on another usb port