DragonBoard™ 410c Stuck in Recovery Mode after Flashing


#1

Hi,

I have followed the instructions in the “Software Build and Installation Guide” and successfully downloaded and built the source code (with build ID “LA.BR.1.2.4-01810-8x16.0”) from Code Aurora. Then I used fastboot to flash the built images to the board. However, after the board boots up, it shows on the monitor that the device is in the recovery mode. I have tried to reboot the board, but it still is in the recovery mode. Could anyone help me with this issue? Thank you!

Here is the screen of the recovery mode that I saw:


#2

Hi @yw374,

I think this is the link where you are referring.

Is it possible to try the Android build from here?


#3

Hello,

“Software Build and Installation Guide” is a generic guide. To build the android images for 410c use the current latest build package from QDN:
https://developer.qualcomm.com/download/db410c/android_board_support_package_vla.br_.1.2.4-01810-8x16.0-3.zip
This zip file has a script DB410c_build.sh, readme and a proprietary tar file which has been created to make it easy for 410c android users to build the images. if you execute DB410c_build.sh it automatically downloads the right source from www.codeaurora.org, apply the relevant patches and generates the output images. you need to flash these images and should not see “recovery issue” that you reported.

Thanks,
Kiran
Qualcomm Innovation Center


#4

Hi @kiran, thanks for your reply! I have just started running the DB410c_build.sh script that you mentioned. Hopefully it will work this time. One more thing, do you know how to attain root access on DragonBoard 410c? After successfully installing the Android OS on the board using images downloaded from here, I have tried several methods (such as Kingo Android Root and SuperSU from this link) to root the device, but none of them succeeded. I’m wondering if you have any suggestion on this issue? Thank you!


#5

Hi @Akira Tsukamoto, thanks for your comment! I was able able to follow through the Android OS installation instructions from the link your suggested. However, I want to have access to the actual source code so that I can make modifications to it later.


#6

Hi @yw374,

Happy to hear that you were able to install Android on your DragonBoard.

This is the link for the documentation about building AOSP from source.


#7

hi@yw374, did your problem solved! I have the same problem, I don’t know what can I do!


#8

hi@kiran
I just execute DB410c_build.sh, and
source build/envsetup.sh
lunch msm8916_64-userdebug
make -j4
then I got this img

android-info.txt
installed-files.txt recovery
boot.img kernel recovery.id
cache obj recovery.img
cache.img obj_arm root
clean_steps.mk ota_temp symbols
data persist system
dt.img persist.img system.img
emmc_appsboot.mbn previous_build_config.mk userdata.img
fake_packages ramdisk.img
gen ramdisk-recovery.img

and I follow this to flah

the end I got, stuck in recovery mode.

root@sj-virtual-machine:/home/sj/Desktop/new/msm8916_64# adb devices
List of devices attached
1f58034b recovery

how to solve it!
best wish!


#9

hello @kiran
i want to ask you why dragonboard 410c is not showing in my laptop? when i try to access it through command prompt i am getting message “adb is not recognized as an internal or external bash command” .
i tried to install usb drivvers and adb drivers but in vain same problem persists ?
what can i do? i am not able to access its GPIO’s? i followed this link but not able to get the solution for this https://www.youtube.com/watch?v=yWSx_BIb7Xs ? please help

Thanks in advance!!!


#10

Sorry @ren_snappy but I’m really confused. In the last three hours you’ve posted that:

  • your board doesn’t boot
  • you cannot get the display working
  • when you boot debian you cannot find any bluetooth icon on the
    display
  • that you are running android and cannot get adb to work
  • that you are have trouble following the board recovery instructions
  • that you can’t get audio to work in yocto/openembedded
  • that you can’t get GPS to work in debian
  • that you have hooked up a DHT11 but don’t know how to talk to it

I’m afraid this is simply too much for me to comprehend and your observations are spread across lots of fairly old forum topics which makes it difficult to connect the dots.

Please do not post any further on this topic unless the people you tagged above choose to engage in the conversation with you. In fact I think it is best that, for the next few days, you simply avoid replying to any existing topics.

Instead please start a new topic carefully describing the symptoms your observe and we will try to help.