Dragoboard 410c: Failed to display remote x-window in Host

When I ssh to my Dragonboard 410c, which runs dragonboard-410c-sdcard-developer-buster-528.img and LXQt (installed by myself), I failed to have any remote window displayed on Host (a Ubuntu 16.04 x86_64).
For example, in ssh shell, running:

linaro@linaro-developer:~$ pcmanfm-qt

will not show anything in ssh shell. Actually, that pcmanfm-qt window will be shown in the LQXt desktop.
And, if I run:

linaro@linaro-developer:~$ sudo gparted

then the following message will appear:

[1] 2510
linaro@linaro-developer:~$ Unit tmp.mount does not exist, proceeding anyway.

(process:2559): Gtk-WARNING **: 12:47:23.436: Locale not supported by C library.
Using the fallback ‘C’ locale.
X11 connection rejected because of wrong authentication.

(gpartedbin:2559): Gtk-WARNING **: 12:47:23.455: cannot open display: localhost:10.0

[1]+ Done sudo gparted

Can anyone comment on this issue?

Did you include the -X argument when calling in with ssh?

I’ve found the solution: Simply copy the ~/.Xauthority to /root/. solves this issue.

linaro@linaro-developer:~$ sudo cp .Xauthority /root/.

Finally this issue is solved!

Sorry, didn’t see your reply until now.
It doesn’t matter whether -X is used or not. The key is, as the I said in my solution, copying the .Xauthority to /root/.

Thanks for your reply, anyway.