Doesn't take serial input after wifi is set

I downloaded latest Debian from

Boots on serial.
I logged in.
Configured wifi over orangepi-config (ssid+pwd)
“reboot now”

I see that it reboots on serial, BUT I cannot input anything over same serial port.
Even after reflashing the SD card and repeating.
This is unsable image.

Any tips?

Last thing on console:

[ OK ] Reached target Local File Systems.
Starting Create Volatile Files and Directories…
Starting Raise network interfaces…
Starting Load/Save RF Kill Switch Status…
[ 7.586975] rda_msys: rda-codec : timeout as sending a message
[ 7.587585] >>>> [aud_StreamRecord], ret [1]
[ 7.729736] wlan_rfkill_set 0
[ OK ] Started Create Volatile Files and Directories.
Starting Network Time Synchronization…
Starting Update UTMP about System Boot/Shutdown…
[ OK ] Started Network Time Synchronization.
[ OK ] Started Update UTMP about System Boot/Shutdown.
[ OK ] Reached target System Time Synchronized.

then I cannot type.

This does not depend on WiFi configuration – it is problem of the Linux " alsa-utils" package.
Folow solution described at OrangePi 2G-IOT: Ubuntu Server only boots one time - Lubuntu - OrangePi - Powered by Discuz!.

Format SD card, write system image to SD card again and after you get initial prompt, before you run orangepi-config, do “sudo apt-get --purge remove alsa-utils”. It worked for me …

… but you can connect even if you do not remove alsa-utils. WiFi should work even console does not, so you can connect using ssh, for example. Just configure ssh server = on. The only problem may be finding out the dynamically assigned IP address. I suggest to change wifi configuration to use static IP address ( You can do it immediately at initialisation and from that moment your board will allways response at the selected IP address …

Thank you, that solved my issue, next one was after a few days the serial port stops working, it responses some overflow error everytime I pressed enter.
Although the wifi+ssh still worked.

Reset solved it, then the wifi stopped working it looping these lines, I had to reset it again:
: wland_sdio_flow_ctrl_91e failed!
[170837.809875] [RDAWLAN_ERR]:<wland_sdio_send_pkt,480>: wland_sdio_flow_ctrl failed!
[170837.810791] [RDAWLAN_ERR]:<wland_proto_cdc_data,232>: set_dcmd failed status: -5
[170837.811706] [RDAWLAN_ERR]:<wland_run_escan,773>: SCAN error (-12)
[170838.847717] [RDAWLAN_ERR]:<wland_sdio_flow_ctrl_91e,392>: flows ctrl RXCMPL failed, count:30 over, return back
[170838.848815] [RDAWLAN_ERR]:<wland_sdio_flow_ctrl,449>: wland_sdio_flow_ctrl_91e failed!

So far this is reliable as windows98.
Is there another distro with the new kernel (5.x)?

No problems with WiFi. USART from time to time fails, but Putty restart solves this. May be used baud rate is too high. I am looking for Real Time OS, so not interested too much in Linux versions for OPi boards. Now I am learnig RIOT on Arduino Nano. Considering install RIOT on OPi i96.