Did something bad just happened


#1

I got my new dragonboard today, really excited to work on some IoT projects. However when i went to power it up using a 9v power supply that from what i could tell was barrel compatible the lights on the board turned on then nothing. after I quickly unplugged it. now i am not sure what to do?

any advice?


#2

Same here, except I was using a 12V power supply. I tried flashing Android multiple times, with no luck. I also tried the recently released Windows 10 Core, same problem. I was about to give up but decided to try Ubuntu and that worked.


#3

Should i at least see some power lights or something when the board powers on?


#4

Except for a micro-second blue flash, I didn’t see lights either. It certainly makes things difficult to tell what’s going on. I would try flashing the board, first with Android and if you still get nothing, try Ubuntu.


#5

Are you trying to boot the original Android OS that comes with the device? You should see a green light turning on after about 20 seconds. It should stay up for a while. Did you check that all dip switches are on 0 position? Also did you connect the HDMI port to a terminal?
Please notice that the micro usb and “MACRO” usb ports can not be used at the same time. If everything goes well a blue light should turn on and stay for the duration of the power on.

Finally it is suggested to use 12V with 2000mA capacity power supply.


#6

I kind of freaked out after seeing the device flash like that. when i tried plugging it back in i didn’t see the same blue flash so i have a decent concern that there maybe something wrong. - I ordered a 12v 2a from arrow from the reccomended psu list on this site. I am just worried if i accidentally fragged the board i don’t know what kind of safe guards are put in place on the dc barrel. Yes the dip switches are in the 0 position.

this is the adapter i used:


#7

I got the adapter today, device turned on no problem. so happy, now to make something awesome!


#8

That’s awesome. Which OS are you using?


#9

I will be using linux, I have some connected home idea’s planned but nothing in stone.


#10

Are you using the Ubuntu distro? If yes, did you try it prior to receiving your new adapter?
Also curious, have you tried Android or Win 10 Core, since you’ve received your adapter?


#11

I don’t really plan on using win-IoT core. Even though I have a background in .NET I don’t see it being compelling enough. especially where the dragon board is new and the IO is 1.8v. which most of my spi/i2c stuff is 3.3v that i have now will need to have a logic level converter to bring it down from 3.3 to the 1.8v. I played with the linaro ubuntu but i am noticing networking issues where i can’t ping my other devices. Might go back to android until the linux scene gets better for this device.

So far I really like it, it’s a bit more nimble than the raspberry pi 2 i own. which before was my fastest device. also when is this getting marshmellow (android 6.0)?


#12

The recommended 12V supply can provide up to 24Watts (12V x 2A). The 9V supply you started with can only provide 13.5Watts (9v x 1.5A), and this might be a little shy to handle momentary peaks when all 4 cores power up, although I am surprised that the board didn’t boot with a 9V supply. Possibly you didn’t wait quite long enough, the boards are a little slow on the first boot. 96Boards are rated to run at any voltage between 8V, and the 410c extends this range a little bit and will run at 6.5V to 18V. Of course as you get to lower voltages you need higher current ratings to provide the same Wattage.


#13

Do you know what the minimum required wattage is to run this board, minus any added peripherals?

Thanks