Defective Board?


#1

First, following the Getting Started guide, I plugged in a USB wireless mouse/keyboard dongle, HDMI cable and a 12V 2.5A power supply. User LED 4 lights up, after about 15 seconds, stays lit for about a minute and then goes out and that’s it, nothing else happens.

I then tried flashing the board with the Android image specified. Followed the same steps as above and also inserted the Micro SD with the Android image. The 96Boards.org Installer screen comes up and I select the only item listed, Build #66 Android release for DragonBoard 410c and click the install button. I confirm the warning about overwriting the contents of my flash and installation begins. It says Flashing has completed and the OS was installed successfully. Per instructions, I remove the SD card, press OK and the board restarts. User LED 4 lights up again, after about 10 seconds, and stays lit for another minute or so, goes out and that’s it, nothing else happens.

I’ve tried this process multiple times, with no luck.


#2

Please could you point me to the document that you are following and attach any logs that you are getting from the host.

Also is it possible that you haven’t unplugged the micro usb connector and/or forgot to modify the switches back to the boot from emmc position? maybe it is still trying to boot from the SD card.


#3

Thanks for the reply.

Here is the link to the instructions I followed: https://www.96boards.org/products/ce/dragonboard410c/

I’m not using a micro usb cable for anything. The first time I tried to start it up, the switches were set to 0010.

When I flashed the board, I set them to 0110. After the board was flashed, I set them back to 0010.


#4

I just noticed the link I posted above doesn’t go to where I thought. If you click the link above, go to the Getting Started menu option. Those are the instructions I followed.


#5

I always use the OTG (micro-usb connector) to flash emmc. I suppose SD will function just as well. In any case, please make sure there is no OTG connector plugged when attempting to boot Android.

BTW the instructions indicate to set the switches to the default: 0-0-0-0 (so it doesn’t attempt to boot from the SD card again). Could you check?


#6

Regardless, I suggest that you follow the instructions documented in the Android pdf user guide [1]

Also, please instead of using the latest release (…/latest/…) use 15.06 [2] with the 40 bootcode [3]; I did try 15.08 on one of my systems without much success.

[1] https://www.96boards.org/products/ce/dragonboard410c/
[2] https://builds.96boards.org/releases/dragonboard410c/qualcomm/android/15.06/
[3] https://builds.96boards.org/releases/dragonboard410c/linaro/rescue/15.06/


#7

Actually 15.08 is fine as well (just make sure you update the aboot partition along with the others)

  1. fastboot flash aboot emmc_appsboot.mbn
  2. fastboot flash persist persist.img
  3. fastboot flash userdata userdata.img
  4. fastboot flash system system.img
  5. fastboot flash cache cache.img
  6. fastboot flash boot boot.img

#8

Thank you for the reply. So far, I’ve only tried flashing from the SD but I’m going try other suggestions, offered by other responses to my post.

Also, yes I have checked to ensure the boot from SD switch is off, after flashing and rebooting.

thanks


#9

I’m going to try this, thank you for the response.


#10

hi,

Side note:
flashing partitions with fastboot vs installing with SD install image is not strictly the same. When flashing with SD install the entire eMMC is reset/reflashed, including all the bootloaders and the GPT partition table. In general, I would recommend to use the SD install, to make sure that the system is in a ‘known’ state, since flashing individual partitions might put your system in an unknown state, unless if you are sure that you reflashed them all properly, including the GPT.

Now about this issue, can you please try to install the Linux SD install image? After reading the messages above, I am tempted to bet that Android doesn’t recognize your monitor. but that’s just a guess. The SD install that you see is running from a small Linux initrd, so it runs with the Linux DRM/KMS display driver, not with the Android display driver. Since you can see the installer, it at least means that the DRM/KMS driver works with your monitor.

If the monitor doesn’t work with Android, you can also try to attach with adb using the OTG USB. Give the board a few mins to boot Android, and then connect USB OTG and run ‘adb devices’ on your PC to check if the board is alive.

Of course, UART traces would definitely tell us more about what’s going on. But if you can run the installer, i believe the board isn’t defective… and that we have a s/w issue.


#11

Hi,
Some additional comments about fastboot install method for Android latest:

ldts wrote: “Also, please instead of using the latest release (…/latest/…) use 15.06 [2] with the 40 bootcode [3]; I did try 15.08 on one of my systems without much success”

Yesterday I also followed instruction in [1] to install the latest Android[4]/Rescue[3] release (…/latest/…) and it didnt show anything at screen after following the instructions. However using the 15.06 Android/Rescue files everything worked out fine.
In addition following [2] to install the latest Linux/Rescue also worked out fine for me.

ldts wrote: “Actually 15.08 is fine as well (just make sure you update the aboot partition along with the others)”

@ldts: I am confused how flashing aboot along others as described by you would help here. Based on my understanding aboot partition is allready flashed as part of executing the ./flashall in the phase “Flash the bootloader into on-board eMMC” ?

ndec wrote “… I am tempted to bet that Android doesn’t recognize your monitor …”
@ndec: That was also my first assumption, but since I verified now it works with 15.06 (and I also observed the one led is on for long time with 15.06 and this doesnt happen with Android latest) there might be another reason?

Any ideas what the above behavior could cause? I also wanted to verify the MD5 checksums for the latest Android to ensure I didnt screw anything during download for the latest Android files [4] but figured out the MD5 Checksum files for the latest Android [4] seem to be missing (md5 checksum files exist in android 15.06)!?

Thanks,
Mark

[1] https://github.com/96boards/documentation/wiki/Dragonboard-410c-Installation-Guide-for-Linux-and-Android#install-android-release

[2] https://github.com/96boards/documentation/wiki/Dragonboard-410c-Installation-Guide-for-Linux-and-Android#install-linaroubuntu-release

[3] http://builds.96boards.org/releases/dragonboard410c/linaro/rescue/latest/dragonboard410c_bootloader_emmc_android*.zip

[4] https://builds.96boards.org/releases/dragonboard410c/qualcomm/android/latest/


#12

Hi Mark,

It could be that the programming sequence is relevant, but I don’t know for sure: all I can say is that I was able to correctly boot release 15.08 and also boot the corresponding AOSP after recompiling from source.

Thanks,


#13

hi,

sorry… i am confused… can you please re-state what images you’ve tried, and which one worked/failed? My understanding is that Android 15.06 and Linux latest worked, and Android 15.08 failed… but i am not sure i got this right.

We will fix the missing MD5SUM soon, thanks for reporting that.

cheers


#14

Hi,

ndec wrote: “My understanding is that Android 15.06 and Linux latest worked, and Android 15.08 failed… but i am not sure i got this right”
@ndec: Yes your understanding is right. I ve been using/downloading the files from Android latest but they should be identical with 15.08 and these somehow failed.

regards,
Mark


#15

Yes, Android ‘latest’ is just a link to 15.08 (well, until the next release…)

Have you used SD install for you testing?

I am afraid the next step to make progress will be access to UART console… Any chance you can get that?


#16

Was the issue in this thread ever resolved?

I recently tried to flash a board with Android (after using Ubuntu on it for several months) and got the same results. The SD install program seems to run normally, but on reboot nothing seems to happen for 10-15 seconds, then one of the green LEDs turns on for a while (maybe 30s, not sure) and then goes out. That’s the only feedback; i.e., nothing on the HDMI monitor.

I tried both the 15.06 and 15.08 releases, using the SD install image to flash the board. On reboot, I tried both the 0-0-0-0 and 0-0-1-0 switch settings. I also tried my usual 1024x768 monitor as well as a couple TVs with HDMI input. For all combinations, I can run the installer but can’t get Android to boot afterwards.

Any suggestions?


#17

Not really. The only success I’ve had, is with Ubuntu. Android hasn’t worked and Win 10 Core only worked partially. I say partially because, using one particular monitor, I was able to get Win 10 running, sort of. I’ve tried about 5 different monitors with this board but only Ubuntu worked on all, Android failed on all. Win 10 Core came up on one of the monitors, but the vertical/horizontal was going haywire, it was a little difficult to work with.

At this point, my question is, will updating drivers or software solve this or is this as good as it gets with this board?


#18

Quick update: I got my board to work with the latest Android image. It appears to only work with 1080p monitors (two that I tested) and not 720p monitors (one that I tested). I also probably wasn’t patient enough during the first boot. It took a little over two minutes for a splash screen to appear briefly, then the screen went blank until the Android lock screen appeared after another minute or so. During the second boot, the whole process took a little under a minute. Note that you might need a mouse or keyboard to wake up the screen if you leave the board unattended during boot up. Otherwise you might return to a blank screen and think the boot didn’t work. That’s what I think happened to me :slight_smile: