Connecting audio devices through analog port

I have followed

aplay –c 0 -D plughw:0,1 /usr/share/sounds/alsa/Front_Center.wav (command from page 10)
is giving me aplay: main:610: value 0 for channels is invalid

has anyone tried doin this?

I have never tried using the analog audio but the command you are quoting look like it is a typo in the documentation from the vendor.

I can’t see how requesting zero channels of audio would ever make sense! Quoting the documentation for aplay (and of course 32 channels is only valid iwhen you have 32 channel audio hardware and such hardware would be difficult or impossible to find):

    -c, --channels=#
        The number of channels.  The default is one channel. 
        Valid values are 1 through 32.

It has the following code

NOTE: The ‘-c 0’ parameter selects the audio hardware instead of pulse audio.
amixer –c 0 cset iface=MIXER,name=‘RX1 MIX1 INP1’ ‘RX1’
amixer –c 0 cset iface=MIXER,name=‘RX2 MIX1 INP1’ ‘RX2’
amixer –c 0 cset iface=MIXER,name=‘RDAC2 MUX’ ‘RX2’
amixer –c 0 cset iface=MIXER,name=‘HPHL’ 1
amixer –c 0 cset iface=MIXER,name=‘HPHR’ 1
amixer –c 0 cset iface=MIXER,name=‘RX1 Digital Volume’ 100

should I change -c 0 to -c 2 ?
how does the channel numbering work if I want stereo audio?

The -c argument to amixer does not mean the number of channels and is probably correct as printed. Quoting the documentation tells us:

    -c card
        Select  the  card  number to control. The device name created from
        this parameter has syntax 'hw:N' where N is specified card number.

found the solution

#configure left channel
amixer cset iface=MIXER,name='DEC1 MUX' 'ADC1'
amixer cset iface=MIXER,name='ADC1 Volume' 100

#configure right channel
amixer cset iface=MIXER,name='DEC2 MUX' 'ADC2'
amixer cset iface=MIXER,name='ADC2 Volume' 100
1 Like