Cant get my new board working

i have bought a new DragonBoard 820c and followed the Getting Started instructions here. I made sure S1 is set ‘0000’ and plugged in HDMI, Mouse+Keyboard, and finally power (12V with 2000mA max).
When the board boots DS10 and BT glow blue and USER LED 1 flashes twice fast in a regular interval, but i get 0 screen output. The Monitor is a modern 2.560 x 1.444, 180hz display from LG and the HDMI cable is double checked. I already tried connecting in EDL mode and flashing as suggested here. But at the end i got no boot partition found instead of LUN1 is now bootable device. Do I need to provide a operation system via the SD Card? Any suggestions? Thank you.

I think the when the “USER LED 1 flashes twice fast in a regular interval” this is the heartbeat indicator. Basically this is a kernel load indicator and follows a heartbeat like rhythm (thump-thump-pause). The key thing is that if you see this pattern then it means that the kernel has booted.

Some ideas to debug are:

  1. Try different monitors if you have any (TVs can be used too if you have only one HDMI monitor).
  2. Try to access the device using the wired network connector. The device will use DHCP to get a network address from your router. If you are lucky the router has a admin page where you can see the allocated addresses and just try them all (ssh linaro@192.168.x.y). If you are unlikely then you can use an nmap sweep to find the device (plug in, sweep, unplug, sweep and compare the difference to learn the IP address).
  3. Use the debug UART to see the boot message. This is a powerful technique but needs extra hardware (the debug UART uses 1.8v signals so you have to get a special adapter) so trying #1 and #2 may be better.

Thanks I was able to access the system via ssh. I can investigate the display issue now.

@Caradhras I’m curious if you figured this out. I’m having the same issue with a new board. I can ssh in but no video when connected to my regular desktop display. I will try some other screens in the house.

Yes, my monitor was to recent for the board, so I turned on HDMI legacy mode and it worked.

@Caradhras Is that a setting in Debian or a setting on your monitor?

@danielt Do you have any ideas?

It does seem to depend on the monitor. My regular TVs would come up at 4k/30 but I found another monitor that would come up at 4k/60.

@endquote No you can set in the monitor.