Can I set 410c android system to auto connect newtwork between boots


#1

Now that I have enabled the 410c board to connect via adb WiFi it would be nice if I did not have to manually turn the WiFi on when the board is started. The board remembers my connection profile so I don’t have to re-enter credentials but I have to use mouse or keyboard to manually enable WiFi before it will connect.


#2

Do you really mean enable WiFi (that should come up automatically) or you mean enable ADB over WiFi (which doesn’t)?


#3

Whenever I power up the 410c with Android OS the WiFi is in the off position. I then need to use my mouse to open settings and go to Wi-Fi and slide the switch with my my mouse to the ON position. So yes I believe that would be called enable WiFi. Perhaps it can be done in one of the boot files such as init.qcom.post_boot.sh?


#4

This problem was identified several times.
I already tried to include codes in the “init.qcomm.pos_boot.sh” but the problem was that I had my WIFI ON but very often no internet connections.
The solution that works for me is to have the WiFi ON and do a clean power OFF. Avoid to pull the power plug. Do a power OFF then, when the LED are OFF pull the plug.
To turn the power OFF press button S2 for a long period and accept the demand to turn OFF.
Check also your profile settings on Android and be sure the WiFi option is correctly set.

You can also try this by ADB.

  1. Power ON
  2. adb root

  3. adb shell

  4. #svc wifi enable
    check if your WiFi is ON by looking at the yellow LED on the board
  5. #reboot -p
    This will power OFF the board
    At the next power ON the WiFi should restart

If this works for you then be sure to turn the Power OFF by either “reboot -p” or pressing on the board power button S2 for a long period. Then accept the demand to turn OFF the device.

Jean-Marc


#5

Thanks for responding with the suggestions. In my case these did not help - I’m sure it will help others however.
What did work was to go into advanced settings and I changed:
Keep WiFi on during sleep: from Always to Never
WiFi Frequency bands : from Automatic to 2.4 Ghz only

Not sure which one or if both made it work but I think this resolved it.
If this reverts back then I will add to this topic otherwise I think it is working.

Best,
Carl


#6

Great! Excellent parameters to verify as well…
Jean-Marc