Can I have the board use eMMC for booting and SD card for rootfs?

Hi,

After getting dragonboard 410c I installed Debian using instructions at https://www.96boards.org/documentation/consumer/dragonboard/dragonboard410c/installation/.

First I installed it to the eMMC using an SD card, and then I found eMMC too small for our project, so I installed Debian to the SD card. I can get the board to boot into Debian on the SD card by switching the boot mode to “boot from SD card”.

However, when booted into Debian on the SD card and when I instruct the board to reboot by executing “reboot” in the terminal, the board ignores the configured boot mode and boots to Debian in the eMMC.

It is important for me I can reboot remotely back to Debian on the SD card. Is there a way I can fix the rebooting issue? If not, is there a way to always boot using eMMC (e.g. have /boot partition in eMMC) and use the SD card for the remaining root fs (excluding /boot)?

Thank you,
Enes

There are two ways to go about this:

  1. remove the bootloaders from the eMMC, you can do this with gdisk, simply delete all the partitions, and if you like, make the entire eMMC an ext4 storage partition, or maybe a couple GB of swap and the remainder storage. If you want to go back to booting from eMMC, just run the SDCard installer.

  2. my preferred solution. Leave the eMMC alone, and always boot from the eMMC. The eMMC is much faster than the SDCard, so you get good system performance. But you are 100% correct, there isn’t enough space in the eMMC to do much, so: Format your SDCard as 2GB of swap and the remainder as ext4. Mount the SDCard, and symlink it to your home directory. I usually call it ~/workspace. Then you can have 30GB+ of workspace to do things like rebuild the kernel on the DragonBoard, or run whatever you need.

Optionally you can create a swap file on the eMMC (not a swap partition), this runs little faster than having the swap on the SDCard.

It’s your DragonBoard do it any way you like.

Thanks @ljking! Tried the first option for now and it worked like a charm.