Buildroot configuration

Apologies for spamming the board the last few days but I’m trying to keep my various issues to separate threads!

I’m attempting the buildroot option, using the guide here:

I haven’t used buildroot before so was hoping some advice could be offered. At what stage in the process outlined above could I alter configurations like enabling ssh, creating user accounts, and other things like Wi-Fi credentials or at least enabling ethernet with dhcp? Basically the stuff I’d need to initially connect it to a network and then access it via SSH. Honestly SSH is the most important, as once I’m in I can do everything else the old fashioned way. Thanks

Related issue:

I’ve reached the stage in the buildroot guide of running

source buildroot/build/

But rockchip_TB-96AIoT is not in the list - in fact the list is a bit garbled; there are about 600 items and most of them seem to be artefacts of a badly parsed ls command.

For now I’m going to try going with the closest/most reasonable match which is rockchip_rk1808 and see what happens.

rootfs and recovery images were apparently not created, or can’t find them. Others seem to be fine.

From the buildroo root dir, you should eb able to execute make menuconfig and select which functions and packages you want to include. You can even overlay filesystem. However, this is a problem if the board is not availble from the envsetup script… we are going to check that with the vendor.

Thanks. I will be retrying later on or tomorrow so I will try to get the exact output.

Sorry for the mistake.

source buildroot/build/

then choose “16. rockchip_rk1808“

Please try this.

Execute the following commands to automatically complete all compiling,
and then all firmware packaged into rockdev directory.


Ethernet with dhcp and ssh services are already enabled in sdk codes
Default ssh account:
username: root
password: rockchip

And also you can login the device by adb interface, if you connect your pc and device using type-c usb cable.

Thanks lodestar. I had tried this but not 100% clear on how to use the result since it doesn’t produce all the files I thought I needed. I appreciate that the details of buildroot aren’t your problem so I will try to muddle through but I might be back with more questions!


By the way, the reason I had garbled output from the source command is because I had ls aliased to ls -l. So not a problem with your tool, but thought you might like to be aware.

Completed the build, got all the files needed, flashed with the upgrade tool and still getting the same error I get with the 2020 image.

@lodestar, would it be possible to update the 96boards documentation.

And, are you aware of this SecureInit ret = -1 issue reported here.