Build issue with Android vLA.BR.1.2.4-01810-8x16.0-3


#1

I downloaded and successfully built Android board support package vLA.BR.1.2.4-01810-8x16.0-3 on my Linux host machine as per instructions in the package.

after that, when I enter the command:

make aboot

inside folder APQ8016_410C_LA.BR.1.2.4-01810-8x16.0_5.1.1_Lollipop_P2, I get the following error message:

"
vendor/qcom/build/tasks/generate_extra_images.mk:490: warning: overriding commands for target kernelclean' device/qcom/common/generate_extra_images.mk:490: warning: ignoring old commands for targetkernelclean’
make: *** No rule to make target gensecimage_target’, needed byaboot’. Stop.

make failed to build some targets (05:13 (mm:ss))

"
performing a search for “gensecimage_target” on the bsp folder(and sub folders) yields no place where this is defined.

Any ideas?


#2

Hi @m375,

I am not so sure at the moment what is happening.

Would you like to trying the source of AOSP Reference Platform build from here?
https://github.com/linaro/documentation/wiki/Reference-Platform-DragonBoard%E2%84%A2-410c-Home


#3

Hi Akira,

Thank you for your reply.
I trust the AOSP build you suggested doesn’t have this problem.
I was trying to know if anybody tried the Android package vLA.BR.1.2.4-01810-8×16.0-3 and run into the problem I mentioned in the original post or not.

Mo


#4

Hi @m375,

I also had the same error message.

make: *** No rule to make target gensecimage_target’, needed byaboot’. Stop.

Let us contact from our side about the error message.


#5

Hi @m375,

Regarding the error with the “make aboot”, please use the following to rebuild bootloader which works.

$ make out/target/product/msm8916_64/emmc_appsboot.mbn

The “make aboot” is not necessary.

Thank you for pointing this out, we will contact the author of revising the documentation.


#6

Thanks for the info.
It seems like this is only an issue with the bootloader build for this release.


#7

Hi Akira,

In your first response in this thread, you suggested AOSP reference build.
I did give it a try and I acn build AOSP successfully but when I was trying to launch kernel config utility on my host for aosp with this command:

make kernelconfig

it didn’t work.

Do you know what is the right command or generally how I could change kernel settings for android aosp build?

Thanks,
Mo


#8

Hi @m375,

The most command I use for customizing kernel config for me is
"make menuconfig"

Does this work for you?


#9

No, not for AOSP.

Neither ‘make kernelconfig’.


#10

Hi,

I used the DB410c_build.sh for syncing repo. It synced the code for LA.BR.1.2.4-01810-8x16.0. At the end there was a message like below. Can you please suggest me what is expected as a next step? I need to build for 410c board.

Applying patches …
applying patches on ./bootable/bootloader/lk …
./DB410c_build.sh: line 44: cd: /home/emtarang/msm8916V/APQ8016_410C_LA.BR.1.2.4-01810-8x16.0_5.1.1_Lollipop_P2/./bootable/bootloader/lk: No such file or directory
./bootable/bootloader/lk does not exist in BUILDROOT:/home/emtarang/msm8916V/APQ8016_410C_LA.BR.1.2.4-01810-8x16.0_5.1.1_Lollipop_P2

Regards,
Vishwanath