Booting Linux kernel with U-Boot

I’m trying to get U-Boot to work on my HiKey 620 board for a project. I’ve tried following the instructions but I keep seeing this error. Ultimately, I would like Android to boot on the HiKey using U-Boot.

I’ve followed the steps in the U-Boot documentation to get it to work on HiKey, but right now not getting very far in the boot.

I’d like to know if anyone has any idea what I did wrong. I’ve tried various scripts to get everything to boot but I’m always getting this error message. I’m looking at the possibility that I have the wrong start address but then I don’t see exactly what it should be.

=> booti $loadaddr - $fdtaddr
Moving Image from 0x10008000 to 0x10080000, end=11681000

Flattened Device Tree blob at 20008000

Booting using the fdt blob at 0x20008000
Using Device Tree in place at 0000000020008000, end 0000000020014c3b

Starting kernel …

“Synchronous Abort” handler, esr 0x02000000
elr: 0000000007206000 lr : 0000000035002f48 (reloc)
elr: 0000000011170000 lr : 000000003ef6cf48
x0 : 0000000020008000 x1 : 0000000000000000
x2 : 0000000000000000 x3 : 0000000000000000
x4 : 0000000010080000 x5 : 0000000000000001
x6 : 0000000000000008 x7 : 0000000000000000
x8 : 000000003e7661a8 x9 : 0000000000000002
x10: 000000000a200023 x11: 0000000000000002
x12: 0000000000000002 x13: 0000000020014c3b
x14: 0000000020008000 x15: 000000003ef6c23c
x16: 000000003ef93778 x17: 0000000000000000
x18: 000000003e767da0 x19: 000000003efe6c70
x20: 0000000000000000 x21: 0000000000000400
x22: 0000000000000003 x23: 000000003e76a5b8
x24: 0000000000000003 x25: 000000003e76a5b8
x26: 000000003efd8880 x27: 0000000000000000
x28: 000000003e76a5e0 x29: 000000003e7661e0

Have you tried the following steps:

I was using U-Boot mainline but apparently not all the patches have gotten in the mainline. I’ll try to see if I can merge the stuff missing from the mainline…

Now I can say I’ve followed the instructions to the letter but I get the same error message when trying to boot.

I’ve tried both with the master U-Boot, and the hikey-mmc-fix branch.

Ok so the problems seem to be related to the kernel I’m using. I’m going to mark this as a solution even though I have not quite solved me problem. It’s unrelated to U-Boot at least.