[Audio issue] How to support Audio Codec on Ubuntu?


Hi , I am new to the Forum.
It can support Audio Codec on Android. But, if I use Ubuntu system, I have Audio Codec issue.
Do I need to install codec driver ? What driver or config do I need to enable ?



what do you call Audio codec? can you provide more details? Also please note that we no longer provide/support Ubuntu ‘builds’ for DB410c, but our builds are now based on Debian (which are equivalent, so if you have an issue with Ubuntu, you will likely have it with Debian as well).



Hi Ndec,
I study the document <lm80-p0436-43_stereocontaudioroutappnote> and play it on Android. DB410C could play well. But I try it on Ubuntu and Debian, the Audio has a problem. I check the /proc/asound. It seems no any PMA8916 (Audio Codec). What documents of Debian/Ubuntu could I refer like stereo on Android ?

root@linaro-alip:~# cd /proc/asound/
root@linaro-alip:/proc/asound# more pcm
00-00: ADV7533 adv7511-0 : : playback 1



it will be supported in the upcoming release (hopefully this week).



The upcoming release is 15.12 ??
as https://builds.96boards.org/releases/dragonboard410c/linaro/debian/


I tried Debian snapshot #61.
When playback using Music player, it only play the audio over HDMI.
How can I hear playback on the earphone connected to the stereo connector.



the upcoming release is not done yet, it will be called 16.02 and will show up at https://builds.96boards.org/releases/dragonboard410c/linaro/debian/ when done. It will be mentioned in the forum as well (there is a pinned thread where we announce releases).

build #61 is our current release candidate for 16.02, indeed, e.g.


with this build, there should be both HDMI audio and analog. You can check you have the 2 sound devices with

root@linaro-alip:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: DB410c [DB410c], device 0: ADV7533 adv7511-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: DB410c [DB410c], device 1: WCD msm8x16_wcd_i2s_rx1-1 []
Subdevices: 1/1
Subdevice #0: subdevice #0

By default if you play a sound , it will use the first device, so HDMI.

To try analog, you can do:

aplay -D plughw:0,1 /usr/share/sounds/alsa/*

It cannot be configured in the ‘audio settings’ configuration UI yet, this is something we will add later.