Anyone has experience connecting mvBlueFox3 camera to the 820c board?


#1

I’ve installed the driver for ARM64 from the Matrix site, the example apps has been compiled successfully, but the camera is not detected by the sample application.
But it is detected by the USB driver as Matrix device.

Any help?
Alex.


#2

Could you please share dmesg and application output to see if any error ?
Do you have device added under /dev/bus/usb ?


#3

The dmesg only shows successful USB connection:
[ 301.722524] usb 1-1.2: new high-speed USB device number 5 using xhci-hcd
and the device is added under /dev/bus/usb.

Update: from the logs that created when i running the application, it shows following message:

Failed to connect to libusb API(Reason: Dynamic Library /opt/mvIMPACT_Acquire/Toolkits/libudev/bin/arm64/lib/libudev not found on the system(-2125))

But the library actually does exists in the required location.


#4

Look like their driver comes with its own libudev version.
Could you please give output of the following command:

file opt/mvIMPACT_Acquire/Toolkits/libudev/bin/arm64/lib/libudev

#5

@Loic,
I run the command file opt/mvIMPACT_Acquire/Toolkits/libudev/bin/arm64/lib/libudev
it gave me the output:
’/opt/mvIMPACT_Acquire/Toolkits/libudev/bin/arm64/lib/libudev.so: symbolic link to libudev.so.1’
After two more symbolic links i finally found the actual library, which gave me the following output:
’/opt/mvIMPACT_Acquire/Toolkits/libudev/bin/arm64/lib/libudev.so.1.3.5: ELF 64-bit LSB shared object, ARM aarch64, version 1 (SYSV), dynamically linked, BuildID[sha1]=024c7df4a127ba34365f8cc36da783fb5153db1c, stripped’

Alex.