Android Recovery Console


#1

I’m trying to install a .zip update and am a bit lost as to how to do it. I accidentally booted into a Android Recovery Mode at one point where the screen was mostly text with red lettering. Is this how i should be installing these types of packages? I’ve tried doing a “adb reboot bootloader” and the screen goes black and never shows anything else, but “fastboot devicecs” responds and lists my device. Installing the .zip with “fastboot update” fails. Is there a su mode i should be in here? Some guidance here would be very helpful.

Ryan


#2

Hi Ryan,

Please visit https://github.com/96boards/documentation/wiki/Dragonboard-410c.
There are guides and manuals there on how to properly install images and packages.

Thanks!


#3

vchong: not what he was asking.

gt1485a: sounds like your red-text-screen may be what you need to install an updater zip. Your only alternative will be to install the files in the zip manually (and making sure to understand what is actually being done in the updater-script within…). Let me guess what this updater zip is… gapps? Be aware that these boards really don’t have all that much RAM to be wasting on bloat like gapps.


#4

doitright: Thanks. Don’t have much option as the app i want requires the Google Licensing Api. Here’s the sequence i finally figured out to get to the Android Recovery Mode:

adb devices(make sure your device shows up)
adb root
adb remount
adb usb
adb reboot recovery

I was then able to try and sideload using the Android Recovery Console. Some of the above may not be necessary but it worked in my case.

re: Gapps
Does the previous link you provided for the uG nogapps project have lower memory requirements? Call me lazy, just trying to avoid having to install and learn another build tool.


#5

It will certainly be much lower on memory requirements. Hopefully, it will satisfy the software you are looking to run.

As far as your command list, the middle THREE commands were unnecessary.

Also note a second (and more reliable) way to get into recovery: press and hold the VOLUME UP button while applying power to the board. Changing that to VOLUME DOWN will get you into fastboot, but note that there is no HDMI display in fastboot on these boards. Probably LK doesn’t know how to work the adv7533.

… in case you bork your android install. This can be easier to deal with than uSD cards :wink:


#6

doitright:

Finally the answer, Volume Up and Power. :slight_smile:

I contacted the developers of MicroG (as my gradle wouldn’t compile it) and it is still in development and not quite ready yet. Seemed that there were multiple caveats and conditions to run it, am going to give it a shot though.


#7

Everything… is always… in development.
Until it is discarded and nobody cares about it any more.

But yeah there are definitely some considerations to be aware of.


#8

@gt1485a
Which gapps package did you use? For me the ones I tried fail with status 7 :confused: